aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2018-06-29 17:43:23 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-02 21:37:58 +0100
commitda37bdad46e11e7ce93ba7a59d58757b769dc16b (patch)
treeda83cfe8a40a2f1714a65fd3feb644e6aa533fc8
parent8efa7826a61501589afa33eb698c0ab3a622bf2e (diff)
downloadbitbake-contrib-da37bdad46e11e7ce93ba7a59d58757b769dc16b.tar.gz
runqueue.py: Fix a virtual class extension stamps issue
The file_name parameter passed to bb.parse.siggen.invalidate_task should be a virtual file name instead of a real file name, or else you will encounter a following error, for instance, when you run: $ bitbake nativesdk-lzip -c unpack -f the error arise: | ERROR: An uncaught exception occurred in runqueue | if file_name: | > taintfn = d.stamp[file_name] + '.' + task + '.taint' | else: | KeyError: 'virtual:nativesdk:/opt/poky/meta/recipes-extended/lzip/lzip_1.19.bb' when multilib builds are used on OE. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bb/runqueue.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/bb/runqueue.py b/lib/bb/runqueue.py
index 2d9e18d88..0a4d15546 100644
--- a/lib/bb/runqueue.py
+++ b/lib/bb/runqueue.py
@@ -1093,7 +1093,7 @@ class RunQueueData:
bb.debug(1, "Task %s is marked nostamp, cannot invalidate this task" % taskname)
else:
logger.verbose("Invalidate task %s, %s", taskname, fn)
- bb.parse.siggen.invalidate_task(taskname, self.dataCaches[mc], fn)
+ bb.parse.siggen.invalidate_task(taskname, self.dataCaches[mc], taskfn)
self.init_progress_reporter.next_stage()