aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2018-02-01 23:15:24 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-09 14:06:02 +0000
commita6a641cb9c5f3abe901b150da915372e295383d7 (patch)
tree1c0c48a0198a24639d71e014677a394fa630ba7d
parentec90245d28e52ea718d2ce084eb304cdc4355c9c (diff)
downloadbitbake-contrib-a6a641cb9c5f3abe901b150da915372e295383d7.tar.gz
bitbake: cooker: don't stop file notifier when cooker is shutdown
It should be live/exited with server rather than cooker, fixed: $ bitbake --server-only -T -1 Set MACHINE = "qemux86" in conf/local.conf $ bitbake quilt Set MACHINE = "qemuppc" in conf/local.conf $ bitbake quilt [snip] ERROR: When reparsing /workspace1/lyang1/poky/meta/recipes-connectivity/openssl/openssl_1.0.2m.bb.do_package, the basehash value changed from c216f7f4fdd3cf4a0b10b975a636426c to d5a8e9431ab261381752d7a64c7b2fa9. The metadata is not deterministic and this needs to be fixed. [snip] This is because the server doesn't know local.conf is changed since the notifiers are stopped, so it doesn't reparse, and then we would get the errors, let the notifiers live/exited with server can fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bb/cooker.py2
-rw-r--r--lib/bb/server/process.py2
2 files changed, 2 insertions, 2 deletions
diff --git a/lib/bb/cooker.py b/lib/bb/cooker.py
index f991c8f12..af482f9d6 100644
--- a/lib/bb/cooker.py
+++ b/lib/bb/cooker.py
@@ -1604,8 +1604,6 @@ class BBCooker:
if self.parser:
self.parser.shutdown(clean=not force, force=force)
- self.notifier.stop()
- self.confignotifier.stop()
def finishcommand(self):
self.state = state.initial
diff --git a/lib/bb/server/process.py b/lib/bb/server/process.py
index 3d31355fd..828159ed7 100644
--- a/lib/bb/server/process.py
+++ b/lib/bb/server/process.py
@@ -223,6 +223,8 @@ class ProcessServer(multiprocessing.Process):
try:
self.cooker.shutdown(True)
+ self.cooker.notifier.stop()
+ self.cooker.confignotifier.stop()
except:
pass