summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-18 22:12:10 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-22 12:16:31 +0100
commit516311946c7bd14c84947dc44c3bb0563e5a9667 (patch)
treecaf8417eb4fb3708bf003cf60b8090ed77ac9ba7 /bin/bitbake
parent94d82997220c6cfc7028f76719df028ba8254a5c (diff)
downloadbitbake-contrib-516311946c7bd14c84947dc44c3bb0563e5a9667.tar.gz
bin/bitbake: Improve --help text
The --help text was rather inconsistent in style and plain incorrect in places, using confusing terminology in others. I guess most people know what the options do and don't read this but its confusing to new users. This updates it to use the terms recipe and task consistently, remove the references to stage, bbread and generally try and make the output more useful. [YOCTO #4856] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake59
1 files changed, 29 insertions, 30 deletions
diff --git a/bin/bitbake b/bin/bitbake
index b4506efb5..509857efa 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -100,59 +100,58 @@ class BitBakeConfigParameters(cookerdata.ConfigParameters):
def parseCommandLine(self):
parser = optparse.OptionParser(
version = "BitBake Build Tool Core version %s, %%prog version %s" % (bb.__version__, __version__),
- usage = """%prog [options] [package ...]
+ usage = """%prog [options] [recipename/target ...]
- Executes the specified task (default is 'build') for a given set of BitBake files.
- It expects that BBFILES is defined, which is a space separated list of files to
- be executed. BBFILES does support wildcards.
- Default BBFILES are the .bb files in the current directory.""")
+ Executes the specified task (default is 'build') for a given set of target recipes (.bb files).
+ It is assumed there is a conf/bblayers.conf available in cwd or in BBPATH which
+ will provide the layer, BBFILES and other configuration information.""")
- parser.add_option("-b", "--buildfile", help = "execute the task against this .bb file, rather than a package from BBFILES. Does not handle any dependencies.",
+ parser.add_option("-b", "--buildfile", help = "Execute tasks from a specific .bb recipe directly. WARNING: Does not handle any dependencies from other recipes.",
action = "store", dest = "buildfile", default = None)
- parser.add_option("-k", "--continue", help = "continue as much as possible after an error. While the target that failed, and those that depend on it, cannot be remade, the other dependencies of these targets can be processed all the same.",
+ parser.add_option("-k", "--continue", help = "Continue as much as possible after an error. While the target that failed and anything depending on it cannot be built, as much as possible will be built before stopping.",
action = "store_false", dest = "abort", default = True)
- parser.add_option("-a", "--tryaltconfigs", help = "continue with builds by trying to use alternative providers where possible.",
+ parser.add_option("-a", "--tryaltconfigs", help = "Continue with builds by trying to use alternative providers where possible.",
action = "store_true", dest = "tryaltconfigs", default = False)
- parser.add_option("-f", "--force", help = "force run of specified cmd, regardless of stamp status",
+ parser.add_option("-f", "--force", help = "Force the specified targets/task to run (invalidating any existing stamp file).",
action = "store_true", dest = "force", default = False)
- parser.add_option("-c", "--cmd", help = "Specify task to execute. Note that this only executes the specified task for the providee and the packages it depends on, i.e. 'compile' does not implicitly call stage for the dependencies (IOW: use only if you know what you are doing). Depending on the base.bbclass a listtasks tasks is defined and will show available tasks",
+ parser.add_option("-c", "--cmd", help = "Specify the task to execute. The exact options available depend on the metadata. Some examples might be 'compile' or 'populate_sysroot' or 'listtasks' may give a list of the tasks available.",
action = "store", dest = "cmd")
- parser.add_option("-C", "--clear-stamp", help = "Invalidate the stamp for the specified cmd such as 'compile' and run the default task for the specified target(s)",
+ parser.add_option("-C", "--clear-stamp", help = "Invalidate the stamp for the specified task such as 'compile' and then run the default task for the specified target(s).",
action = "store", dest = "invalidate_stamp")
- parser.add_option("-r", "--read", help = "read the specified file before bitbake.conf",
+ parser.add_option("-r", "--read", help = "Read the specified file before bitbake.conf.",
action = "append", dest = "prefile", default = [])
- parser.add_option("-R", "--postread", help = "read the specified file after bitbake.conf",
+ parser.add_option("-R", "--postread", help = "Read the specified file after bitbake.conf.",
action = "append", dest = "postfile", default = [])
- parser.add_option("-v", "--verbose", help = "output more chit-chat to the terminal",
+ parser.add_option("-v", "--verbose", help = "Output more log message data to the terminal.",
action = "store_true", dest = "verbose", default = False)
parser.add_option("-D", "--debug", help = "Increase the debug level. You can specify this more than once.",
action = "count", dest="debug", default = 0)
- parser.add_option("-n", "--dry-run", help = "don't execute, just go through the motions",
+ parser.add_option("-n", "--dry-run", help = "Don't execute, just go through the motions.",
action = "store_true", dest = "dry_run", default = False)
- parser.add_option("-S", "--dump-signatures", help = "don't execute, just dump out the signature construction information",
+ parser.add_option("-S", "--dump-signatures", help = "Don't execute, just dump out the signature construction information.",
action = "store_true", dest = "dump_signatures", default = False)
- parser.add_option("-p", "--parse-only", help = "quit after parsing the BB files (developers only)",
+ parser.add_option("-p", "--parse-only", help = "Quit after parsing the BB recipes.",
action = "store_true", dest = "parse_only", default = False)
- parser.add_option("-s", "--show-versions", help = "show current and preferred versions of all recipes",
+ parser.add_option("-s", "--show-versions", help = "Show current and preferred versions of all recipes.",
action = "store_true", dest = "show_versions", default = False)
- parser.add_option("-e", "--environment", help = "show the global or per-package environment (this is what used to be bbread)",
+ parser.add_option("-e", "--environment", help = "Show the global or per-package environment complete with information about where variables were set/changed.",
action = "store_true", dest = "show_environment", default = False)
- parser.add_option("-g", "--graphviz", help = "emit the dependency trees of the specified packages in the dot syntax, and the pn-buildlist to show the build list",
+ parser.add_option("-g", "--graphviz", help = "Save dependency tree information for the specified targets in the dot syntax.",
action = "store_true", dest = "dot_graph", default = False)
parser.add_option("-I", "--ignore-deps", help = """Assume these dependencies don't exist and are already provided (equivalent to ASSUME_PROVIDED). Useful to make dependency graphs more appealing""",
@@ -161,34 +160,34 @@ class BitBakeConfigParameters(cookerdata.ConfigParameters):
parser.add_option("-l", "--log-domains", help = """Show debug logging for the specified logging domains""",
action = "append", dest = "debug_domains", default = [])
- parser.add_option("-P", "--profile", help = "profile the command and print a report",
+ parser.add_option("-P", "--profile", help = "Profile the command and save reports.",
action = "store_true", dest = "profile", default = False)
- parser.add_option("-u", "--ui", help = "userinterface to use",
+ parser.add_option("-u", "--ui", help = "The user interface to use (e.g. knotty, hob, depexp).",
action = "store", dest = "ui")
- parser.add_option("-t", "--servertype", help = "Choose which server to use, process or xmlrpc",
+ parser.add_option("-t", "--servertype", help = "Choose which server to use, process or xmlrpc.",
action = "store", dest = "servertype")
- parser.add_option("", "--revisions-changed", help = "Set the exit code depending on whether upstream floating revisions have changed or not",
+ parser.add_option("", "--revisions-changed", help = "Set the exit code depending on whether upstream floating revisions have changed or not.",
action = "store_true", dest = "revisions_changed", default = False)
- parser.add_option("", "--server-only", help = "Run bitbake without UI, the frontend can connect with bitbake server itself",
+ parser.add_option("", "--server-only", help = "Run bitbake without a UI, only starting a server (cooker) process.",
action = "store_true", dest = "server_only", default = False)
- parser.add_option("-B", "--bind", help = "The name/address for the bitbake server to bind to",
+ parser.add_option("-B", "--bind", help = "The name/address for the bitbake server to bind to.",
action = "store", dest = "bind", default = False)
- parser.add_option("", "--no-setscene", help = "Do not run any setscene tasks, forces builds",
+ parser.add_option("", "--no-setscene", help = "Do not run any setscene tasks. sstate will be ignored and everything needed, built.",
action = "store_true", dest = "nosetscene", default = False)
- parser.add_option("", "--remote-server", help = "Connect to the specified server",
+ parser.add_option("", "--remote-server", help = "Connect to the specified server.",
action = "store", dest = "remote_server", default = False)
- parser.add_option("-m", "--kill-server", help = "Terminate the remote server",
+ parser.add_option("-m", "--kill-server", help = "Terminate the remote server.",
action = "store_true", dest = "kill_server", default = False)
- parser.add_option("", "--observe-only", help = "Connect to a server as an observing-only client",
+ parser.add_option("", "--observe-only", help = "Connect to a server as an observing-only client.",
action = "store_true", dest = "observe_only", default = False)
options, targets = parser.parse_args(sys.argv)