summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2011-07-22 10:21:00 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-25 12:50:23 +0100
commit54c7206165c0e7cfe5f7b243c80461baf5e7dfb1 (patch)
tree4db01357db7a80ae848b0cb0ec008ba34a3ad0e7 /bin/bitbake
parent0cbf5dcaf9f67522bd58d868aa01f28e846dfc19 (diff)
downloadbitbake-contrib-54c7206165c0e7cfe5f7b243c80461baf5e7dfb1.tar.gz
bitbake|cooker: save a copy of the environment when BitBake is started
Create a data store in the cooker containing the values of the environment from when BitBake is launched such that child processes can replicate (and/or use values from) the host environment, rather than the cleaned up environment that the main BitBake process uses. Signed-off-by: Joshua Lock <josh@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake5
1 files changed, 4 insertions, 1 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 8d6fef7b8..5398cf122 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -197,6 +197,9 @@ Default BBFILES are the .bb files in the current directory.""")
handler = bb.event.LogHandler()
logger.addHandler(handler)
+ # Before we start modifying the environment we should take a pristine
+ # copy for possible later use
+ initialenv = os.environ.copy()
# Clear away any spurious environment variables. But don't wipe the
# environment totally. This is necessary to ensure the correct operation
# of the UIs (e.g. for DISPLAY, etc.)
@@ -207,7 +210,7 @@ Default BBFILES are the .bb files in the current directory.""")
server.initServer()
idle = server.getServerIdleCB()
- cooker = bb.cooker.BBCooker(configuration, idle)
+ cooker = bb.cooker.BBCooker(configuration, idle, initialenv)
cooker.parseCommandLine()
server.addcooker(cooker)