summaryrefslogtreecommitdiffstats
path: root/lib/bb/command.py
diff options
context:
space:
mode:
authorCristiana Voicu <cristiana.voicu@intel.com>2013-07-29 10:02:24 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-06 12:59:21 +0100
commit5629007f2b984005e3a8ac5d9b71422cbc2f1409 (patch)
treea9b0bc4e9c429cd4a5ac5dd27b73dbdc9ba558c4 /lib/bb/command.py
parent96ffa00945c7eb09a0132fa47159aef3ef20fb3e (diff)
downloadbitbake-contrib-5629007f2b984005e3a8ac5d9b71422cbc2f1409.tar.gz
hob/bitbake: save the description of a custom image
When an new image is saved, the dialog for this action has a field for the description. Changed how an image is saved, by appending the DESCRIPTION variable at the end of the .bb file. [YOCTO #4193] Signed-off-by: Cristiana Voicu <cristiana.voicu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/command.py')
-rw-r--r--lib/bb/command.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/bb/command.py b/lib/bb/command.py
index 1893cce71..5eb34aff3 100644
--- a/lib/bb/command.py
+++ b/lib/bb/command.py
@@ -215,8 +215,9 @@ class CommandsSync:
base_image = params[1]
package_queue = params[2]
timestamp = params[3]
+ description = params[4]
return command.cooker.generateNewImage(image, base_image,
- package_queue, timestamp)
+ package_queue, timestamp, description)
def ensureDir(self, command, params):
directory = params[0]