summaryrefslogtreecommitdiffstats
path: root/lib/bb/parse/__init__.py
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-02-17 14:07:40 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-17 15:30:02 +0000
commit22e03ef7ac9bb6b7245250347ae9c10c19f1d74e (patch)
tree5c43fa8bdcff2d9fbee7350c034adc17104980da /lib/bb/parse/__init__.py
parentf975ca2cf728561bd6317ed8f76303598546113a (diff)
downloadbitbake-contrib-22e03ef7ac9bb6b7245250347ae9c10c19f1d74e.tar.gz
parse: make vars_from_file return None for non-recipes
It doesn't really make sense to set PN from .conf files, for example. More concretely, this avoids the config hash changing unnecessarily within Hob due to PN effectively changing (since bblayers.conf is parsed first and then .hob.conf). Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/parse/__init__.py')
-rw-r--r--lib/bb/parse/__init__.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/bb/parse/__init__.py b/lib/bb/parse/__init__.py
index 97983c988..e4a44dda1 100644
--- a/lib/bb/parse/__init__.py
+++ b/lib/bb/parse/__init__.py
@@ -127,7 +127,7 @@ def resolve_file(fn, d):
# Used by OpenEmbedded metadata
__pkgsplit_cache__={}
def vars_from_file(mypkg, d):
- if not mypkg:
+ if not mypkg or not mypkg.endswith((".bb", ".bbappend")):
return (None, None, None)
if mypkg in __pkgsplit_cache__:
return __pkgsplit_cache__[mypkg]