aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bblayers
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2016-05-31 11:16:58 +1200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-02 22:10:28 +0100
commita609ad7d560260a8d50dfa197cd960f496c5da73 (patch)
tree2b8bda347185aceb38c28111fd9e162af86e6834 /lib/bblayers
parentfde5c962cb69a11b072d1f238c2371a5137d030d (diff)
downloadbitbake-contrib-a609ad7d560260a8d50dfa197cd960f496c5da73.tar.gz
bitbake-layers: show-layers: disable parsing
We don't need to parse all recipes just to show the list of layers, since that comes straight from the configuration, so save a bit of time by not doing so. (A minor regression that came in with the the bitbake-layers refactoring). Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bblayers')
-rw-r--r--lib/bblayers/query.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/bblayers/query.py b/lib/bblayers/query.py
index b8c817b12..0a496810f 100644
--- a/lib/bblayers/query.py
+++ b/lib/bblayers/query.py
@@ -481,7 +481,7 @@ NOTE: .bbappend files can impact the dependencies.
logger.plain("%s %s %s" % (f, keyword, best_realfn))
def register_commands(self, sp):
- self.add_command(sp, 'show-layers', self.do_show_layers)
+ self.add_command(sp, 'show-layers', self.do_show_layers, parserecipes=False)
parser_show_overlayed = self.add_command(sp, 'show-overlayed', self.do_show_overlayed)
parser_show_overlayed.add_argument('-f', '--filenames', help='instead of the default formatting, list filenames of higher priority recipes with the ones they overlay indented underneath', action='store_true')