aboutsummaryrefslogtreecommitdiffstats
path: root/lib/toaster/toastergui/templates
diff options
context:
space:
mode:
authorBelen Barros Pena <belen.barros.pena@intel.com>2014-03-16 13:09:34 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-05 14:55:18 +0100
commitce89530b178be2f3202d45523ef1340e00df05be (patch)
tree9f939d119b022240f5b1aaa6ad3165f629d3c9f0 /lib/toaster/toastergui/templates
parent471234f1ab1dbcd736a892720e99a305363db5ff (diff)
downloadbitbake-contrib-ce89530b178be2f3202d45523ef1340e00df05be.tar.gz
toaster: Changes to help text
All help text strings have been reviewed by the technical writer, and some of them by Paul Eggleton. This patch implements their suggested changes. Signed-off-by: Belen Barros Pena <belen.barros.pena@intel.com>
Diffstat (limited to 'lib/toaster/toastergui/templates')
-rw-r--r--lib/toaster/toastergui/templates/builddashboard.html20
-rw-r--r--lib/toaster/toastergui/templates/package_built_dependencies.html4
-rw-r--r--lib/toaster/toastergui/templates/package_built_detail.html6
-rw-r--r--lib/toaster/toastergui/templates/package_detail_base.html4
-rw-r--r--lib/toaster/toastergui/templates/package_included_dependencies.html2
-rw-r--r--lib/toaster/toastergui/templates/package_included_tabs.html2
-rw-r--r--lib/toaster/toastergui/templates/recipe.html16
-rw-r--r--lib/toaster/toastergui/templates/task.html34
8 files changed, 50 insertions, 38 deletions
diff --git a/lib/toaster/toastergui/templates/builddashboard.html b/lib/toaster/toastergui/templates/builddashboard.html
index 65631286b..6cce7883b 100644
--- a/lib/toaster/toastergui/templates/builddashboard.html
+++ b/lib/toaster/toastergui/templates/builddashboard.html
@@ -84,7 +84,7 @@
<dt>Total package size</dt>
<dd>{{target.pkgsz|filtered_filesizeformat}}</dd>
<dt>
- <i class="icon-question-sign get-help" title="The location in disk of the license manifest, a document listing all packages installed in your image and their licenses"></i>
+ <i class="icon-question-sign get-help" title="Path to the license manifest, which is a document listing all packages installed in your image and their licenses"></i>
License manifest
</dt>
<dd><a href="{% url 'targetpackages' build.pk target.target.pk %}"><code>{{target.target.license_manifest_path}}</code></a></dd>
@@ -126,9 +126,21 @@
<h4><a href="{%url 'tasks' build.pk%}">Tasks</a></h4>
<dl>
<dt>Total number of tasks</dt><dd><a href="{% url 'tasks' build.pk %}">{{build.task_build.all.count}}</a></dd>
- <dt>Tasks executed</dt><dd><a href="{% url 'tasks' build.pk %}?filter=task_executed%3A1&amp;count=25&amp;search=&amp;page=1&amp;orderby=order%3A%2B">{% query build.task_build task_executed=1 order__gt=0 as exectask%}{{exectask.count}}</a></dd>
- <dt>Tasks not executed</dt><dd><a href="{% url 'tasks' build.pk %}?filter=task_executed%3A0&amp;count=25&amp;search=&amp;page=1&amp;orderby=order%3A%2B">{% query build.task_build task_executed=0 order__gt=0 as noexectask%}{{noexectask.count}}</a></dd>
- <dt>Reuse</dt><dd>
+ <dt>
+ Tasks executed
+ <i class="icon-question-sign get-help" title="'Executed' tasks are those that need to be run in order to generate the task output"></i>
+ </dt>
+ <dd><a href="{% url 'tasks' build.pk %}?filter=task_executed%3A1&amp;count=25&amp;search=&amp;page=1&amp;orderby=order%3A%2B">{% query build.task_build task_executed=1 order__gt=0 as exectask%}{{exectask.count}}</a></dd>
+ <dt>
+ Tasks not executed
+ <i class="icon-question-sign get-help" title="'Not executed' tasks don't need to run because their outcome is provided by another task"></i>
+ </dt>
+ <dd><a href="{% url 'tasks' build.pk %}?filter=task_executed%3A0&amp;count=25&amp;search=&amp;page=1&amp;orderby=order%3A%2B">{% query build.task_build task_executed=0 order__gt=0 as noexectask%}{{noexectask.count}}</a></dd>
+ <dt>
+ Reuse
+ <i class="icon-question-sign get-help" title="The percentage of 'not executed' tasks over the total number of tasks, which is a measure of the efficiency of your build"></i>
+ </dt>
+ <dd>
{% query build.task_build order__gt=0 as texec %}
{% if noexectask.count|multiply:100|divide:texec.count < 0 %}
0
diff --git a/lib/toaster/toastergui/templates/package_built_dependencies.html b/lib/toaster/toastergui/templates/package_built_dependencies.html
index 8613f1e73..4e86da519 100644
--- a/lib/toaster/toastergui/templates/package_built_dependencies.html
+++ b/lib/toaster/toastergui/templates/package_built_dependencies.html
@@ -24,7 +24,7 @@
</div>
{% else %}
<div class="alert alert-info">
- <strong>{{package.fullpackagespec}}</strong> is <strong>not included</strong> in any image. These are its projected runtime dependencies if you were to include it in future builds.
+ <strong>{{package.fullpackagespec}}</strong> is <strong>not included</strong> in any image. This page shows you the projected runtime dependencies if you include <strong>{{package.fullpackagespec}}</strong> in future builds.
</div>
<table class="table table-bordered table-hover">
<thead>
@@ -64,7 +64,7 @@
<th>Version</th>
<th>Size</th>
<th>
- <i class="icon-question-sign get-help" title="There are 5 relationship types: recommends, suggests, provides, replaces and conflicts"></i>
+ <i class="icon-question-sign get-help" title="Five relationship types exist: recommends, suggests, provides, replaces and conflicts"></i>
Relationship type
</th>
</tr>
diff --git a/lib/toaster/toastergui/templates/package_built_detail.html b/lib/toaster/toastergui/templates/package_built_detail.html
index 6ccd4056c..3aa1b2a8a 100644
--- a/lib/toaster/toastergui/templates/package_built_detail.html
+++ b/lib/toaster/toastergui/templates/package_built_detail.html
@@ -8,11 +8,11 @@
{# Not included case #}
<ul class="nav nav-pills">
<li class="active"> <a href="#">
- <i class="icon-question-sign get-help" data-toggle="tooltip" title="Files that would be added to a root file system if you were to include {{package.name}} in an image"></i>
+ <i class="icon-question-sign get-help" data-toggle="tooltip" title="Files added to a root file system when you include {{package.name}} in an image"></i>
Generated files ({{packageFileCount}})
</a></li>
<li class=""><a href="{% url 'package_built_dependencies' build.id package.id %}">
- <i class="icon-question-sign get-help" data-toggle="tooltip" title="Projected runtime dependencies if you were to include {{package.name}} in an image"></i>
+ <i class="icon-question-sign get-help" data-toggle="tooltip" title="Projected runtime dependencies when you include {{package.name}} in an image"></i>
Runtime dependencies ({{dependency_count}})
</a></li>
</ul>
@@ -21,7 +21,7 @@
<!-- Package file list or if empty, alert pane -->
{% if packageFileCount > 0 %}
<div class="alert alert-info">
- {{package.fullpackagespec}} is <strong>not included</strong> in any image. These are the files that would be added to an image root file system if you were to include it in future builds.
+ <strong>{{package.fullpackagespec}}</strong> is <strong>not included</strong> in any image. This page shows you the files added to an image root file system if you include <strong>{{package.fullpackagespec}}</strong> in future builds.
</div>
<table class="table table-bordered table-hover">
<thead>
diff --git a/lib/toaster/toastergui/templates/package_detail_base.html b/lib/toaster/toastergui/templates/package_detail_base.html
index 5ec9dd79f..588851348 100644
--- a/lib/toaster/toastergui/templates/package_detail_base.html
+++ b/lib/toaster/toastergui/templates/package_detail_base.html
@@ -83,7 +83,7 @@
# problemse are resolved.
<dt>
License files
- <i class="icon-question-sign get-help" data-toggle="tooltip" title="Location in disk of the license files that apply to the package"></i>
+ <i class="icon-question-sign get-help" data-toggle="tooltip" title="Path to the license files that apply to the package"></i>
</dt>
<dd></dd>
{% endcomment %}
@@ -136,7 +136,7 @@
<dd class="iscommit">{{package.recipe.layer_version.commit}}</dd>
<dt>
Layer directory
- <i class="icon-question-sign get-help" data-toggle="tooltip" title="Location in disk of the layer providing the recipe that builds this package"></i>
+ <i class="icon-question-sign get-help" data-toggle="tooltip" title="Path to the layer providing the recipe that builds this package"></i>
</dt>
<dd><code>{{package.recipe.layer_version.layer.local_path}}</code></dd>
</dl>
diff --git a/lib/toaster/toastergui/templates/package_included_dependencies.html b/lib/toaster/toastergui/templates/package_included_dependencies.html
index e06e07368..9169ee95d 100644
--- a/lib/toaster/toastergui/templates/package_included_dependencies.html
+++ b/lib/toaster/toastergui/templates/package_included_dependencies.html
@@ -59,7 +59,7 @@
<th>Version</th>
<th>Size</th>
<th>
- <i class="icon-question-sign get-help" title="There are 5 relationship types: recommends, suggests, provides, replaces and conflicts"></i>
+ <i class="icon-question-sign get-help" title="Five relationship types exist: recommends, suggests, provides, replaces and conflicts"></i>
Relationship type
</th>
</tr>
diff --git a/lib/toaster/toastergui/templates/package_included_tabs.html b/lib/toaster/toastergui/templates/package_included_tabs.html
index 3ea49152a..0140b03c0 100644
--- a/lib/toaster/toastergui/templates/package_included_tabs.html
+++ b/lib/toaster/toastergui/templates/package_included_tabs.html
@@ -26,7 +26,7 @@
<li class="">
{% endif %}
<a href="{% url 'package_included_reverse_dependencies' build.id target.id package.id %}">
- <i class="icon-question-sign get-help" data-toggle="tooltip" title="The package runtime reverse dependencies (i.e. which other packages in this image depend on this package). Reverse dependencies reflect only the 'depends' dependency type"></i>
+ <i class="icon-question-sign get-help" data-toggle="tooltip" title="The package runtime reverse dependencies (i.e. the packages in this image that depend on this package). Reverse dependencies reflect only the 'depends' dependency type"></i>
Reverse runtime dependencies ({{reverse_count}})
</a>
</li>
diff --git a/lib/toaster/toastergui/templates/recipe.html b/lib/toaster/toastergui/templates/recipe.html
index b8898d2b9..c846aa934 100644
--- a/lib/toaster/toastergui/templates/recipe.html
+++ b/lib/toaster/toastergui/templates/recipe.html
@@ -33,13 +33,13 @@
</li>
<li>
<a href="#dependencies" data-toggle="tab">
- <i class="icon-question-sign get-help" data-toggle="tooltip" title="The recipe build-time dependencies (other recipes)"></i>
+ <i class="icon-question-sign get-help" data-toggle="tooltip" title="The recipe build-time dependencies (i.e. other recipes)"></i>
Build dependencies ({{object.r_dependencies_recipe.all.count}})
</a>
</li>
<li>
<a href="#brought-in-by" data-toggle="tab">
- <i class="icon-question-sign get-help" data-toggle="tooltip" title="The recipe build-time reverse dependencies (i.e. which other recipes depend on this recipe)"></i>
+ <i class="icon-question-sign get-help" data-toggle="tooltip" title="The recipe build-time reverse dependencies (i.e. the recipes that depend on this recipe)"></i>
Reverse build dependencies ({{object.r_dependencies_depends.all.count}})
</a>
</li>
@@ -53,12 +53,12 @@
</dt>
<dd>{{layer.name}}</dd>
<dt>
- <i class="icon-question-sign get-help" data-toggle="tooltip" title="Location in disk of the layer providing the recipe"></i>
+ <i class="icon-question-sign get-help" data-toggle="tooltip" title="Path to the layer providing the recipe"></i>
Layer directory
</dt>
<dd><code>{{layer.local_path}}</code></dd>
<dt>
- <i class="icon-question-sign get-help" data-toggle="tooltip" title="Location in disk of the recipe .bb file"></i>
+ <i class="icon-question-sign get-help" data-toggle="tooltip" title="Path to the recipe .bb file"></i>
Recipe file
</dt>
<dd><code>{{object.file_path}}</code></dd>
@@ -91,15 +91,15 @@
Task
</th>
<th>
- <i class="icon-question-sign get-help" title="This value tells you if a task had to run in order to generate the task output (executed), or if the output was provided by another task and therefore the task didn't need to run (not executed)"></i>
+ <i class="icon-question-sign get-help" title="This value tells you if a task had to run (executed) in order to generate the task output, or if the output was provided by another task and therefore the task didn't need to run (not executed)"></i>
Executed
</th>
<th>
- <i class="icon-question-sign get-help" title="This column tells you if executed tasks succeeded, failed or reused output from the sstate-cache directory or mirrors. It also tells you why not executed tasks did not need to run"></i>
+ <i class="icon-question-sign get-help" title="This column tells you if 'executed' tasks succeeded or failed. The column also tells you why 'not executed' tasks did not need to run"></i>
Outcome
</th>
<th>
- <i class="icon-question-sign get-help" title="This column tells you if a task tried to restore output from the <code>sstate-cache</code> directory or mirros, and what was the result: Succeeded, Failed or File not in cache"></i>
+ <i class="icon-question-sign get-help" title="This column tells you if a task tried to restore output from the <code>sstate-cache</code> directory or mirrors, and reports the result: Succeeded, Failed or File not in cache"></i>
Cache attempt
</th>
</thead>
@@ -259,7 +259,7 @@
{% if object.section %}
<dt>
Section
- <i class="icon-question-sign get-help" data-toggle="tooltip" title="The section in which recipes should be categorised"></i>
+ <i class="icon-question-sign get-help" data-toggle="tooltip" title="The section in which recipes should be categorized"></i>
</dt>
<dd>{{object.section}}</dd>
{% endif %}
diff --git a/lib/toaster/toastergui/templates/task.html b/lib/toaster/toastergui/templates/task.html
index 5c32250be..c1504b604 100644
--- a/lib/toaster/toastergui/templates/task.html
+++ b/lib/toaster/toastergui/templates/task.html
@@ -25,7 +25,7 @@
<dl class="dl-horizontal">
{% if task.logfile %}
<dt>
- <i class="icon-question-sign get-help" title="The location in disk of the task log file"></i> Log file
+ <i class="icon-question-sign get-help" title="Path the task log file"></i> Log file
</dt>
<dd>
<code>{{task.logfile}}</code>
@@ -46,10 +46,10 @@
{# not executed tasks outcome #}
{% if task.outcome == task.OUTCOME_PREBUILT %}
{% if not showing_matches %}
- <a class="btn" href="javascript:reload_params({'show_matches' : 'true' })">Match to tasks in previous builds <i class="icon-question-sign get-help" style="margin-top:20px;" data-toggle="tooltip" title="This will show you a list of tasks from previous builds with the same inputs signature as this prebuilt task. Any of them could be the task that generated the output this prebuilt task is reusing"></i></a>
+ <a class="btn" href="javascript:reload_params({'show_matches' : 'true' })">Match to tasks in previous builds <i class="icon-question-sign get-help" style="margin-top:20px;" data-toggle="tooltip" title="This shows you a list of tasks from previous builds with the same signature generated from the same inputs as used in the prebuilt task. Any of them could be the task that generated the output this prebuilt task is reusing"></i></a>
{% elif matching_tasks %}
<h3 class="details">Prebuilt task could be based on
- <i class="icon-question-sign get-help heading-help" title="This table shows a list of tasks from previous builds with the same inputs signature as the prebuilt task. Any of them could be the task that generated the output the prebuilt task is reusing"></i>
+ <i class="icon-question-sign get-help heading-help" title="This table shows a list of tasks from previous builds with the same signature generated from the same inputs as used in the prebuilt task. Any of them could be the task that generated the output this prebuilt task is reusing"></i>
</h3>
<table class="table table-bordered table-hover">
<thead>
@@ -62,11 +62,11 @@
Task
</th>
<th>
- <i class="icon-question-sign get-help" title="This value tells you if a task had to run in order to generate the task output (executed), or if the output was provided by another task and therefore the task didn't need to run (not executed)"></i>
+ <i class="icon-question-sign get-help" title="This value tells you if a task had to run (executed) in order to generate the task output, or if the output was provided by another task and therefore the task didn't need to run (not executed)"></i>
Executed
</th>
<th>
- <i class="icon-question-sign get-help" title="This column tells you if executed tasks succeeded, failed or reused output from the sstate-cache directory or mirrors. It also tells you why not executed tasks did not need to run"></i>
+ <i class="icon-question-sign get-help" title="This column tells you if 'executed' tasks succeeded or failed. The column also tells you why 'not executed' tasks did not need to run"></i>
Outcome
</th>
<th>
@@ -116,7 +116,7 @@
{%elif task.outcome == task.OUTCOME_CACHED%}
<dl class="dl-horizontal">
<dt>
- <i class="icon-question-sign get-help" title="The location in disk of the task log file"></i> Log file
+ <i class="icon-question-sign get-help" title="Path the task log file"></i> Log file
</dt>
<dd>
<code>{% for t in task.get_related_setscene %} {{t.logfile}} {% endfor %}</code>
@@ -133,11 +133,11 @@
{% if task.task_executed %}
<h2>
Executed
- <i class="icon-question-sign get-help heading-help" title="Executed tasks are those that need to run in order to generate the task output"></i>
+ <i class="icon-question-sign get-help heading-help" title="'Executed' tasks are those that need to run in order to generate the task output"></i>
{% else %}
<h2 class="muted">
Not Executed
- <i class="icon-question-sign get-help heading-help" title="Not executed tasks don't need to run because their outcome is provided by another task"></i>
+ <i class="icon-question-sign get-help heading-help" title="'Not executed' tasks don't need to run because their outcome is provided by another task"></i>
{% endif %}
</h2>
<dl class="dl-horizontal">
@@ -151,7 +151,7 @@
{% if task.sstate_result != task.SSTATE_NA %}
</dl>
<div class="alert alert-info">Attempting to restore output from sstate cache
- <i class="icon-question-sign get-help get-help-blue" title="The build system is searching for the task output in your <code>sstate-cache</code> directory and mirrors. If it finds it, it will use it instead of building it from scratch by running the real task. This makes the build faster"></i>
+ <i class="icon-question-sign get-help get-help-blue" title="The build system is searching for the task output in your <code>sstate-cache</code> directory and mirrors. If the build system finds the task output, it will reuse it instead of building it from scratch by running the real task. Reusing the task output makes the build faster"></i>
</div>
<dl class="dl-horizontal">
<dt>
@@ -160,7 +160,7 @@
</dt>
<dd><code>{{task.path_to_sstate_obj}}</code></dd>
<dt>
- <i class="icon-question-sign get-help" title="The locations where the above file was searched: your <code>sstate-cache</code> directory and the mirrors you have set up (if any)"></i>
+ <i class="icon-question-sign get-help" title="The locations searched for the above file (i.e. your <code>sstate-cache</code> directory and any mirrors you have set up)"></i>
URI(s) searched
</dt>
<dd><code>{{task.work_directory}}</code></dd>
@@ -176,12 +176,12 @@
</div>
<dl class="dl-horizontal">
<dt>
- <i class="icon-question-sign get-help" title="The location in disk of the cache attempt log file"></i>
+ <i class="icon-question-sign get-help" title="Path to the cache attempt log file"></i>
Log file
</dt>
<dd><code>{{task.logfile}}</code></dd>
<dt>
- <i class="icon-question-sign get-help" title="How long it took the cache attempt to finish, expressed in seconds"></i>
+ <i class="icon-question-sign get-help" title="How long it took the cache attempt to finish in seconds"></i>
Time (secs)
</dt>
<dd>{{task.elapsed_time|format_none_and_zero}}</dd>
@@ -202,7 +202,7 @@
<dd><a href="{%url "tasks_task" build.pk task.order %}#{{task.order}}">{{task.order}}</a></dd>
{% if task.task_executed %}
<dt>
- <i class="icon-question-sign get-help" title="If this task executes a Python or Shell function(s)"></i>
+ <i class="icon-question-sign get-help" title="Indicates if this task executes a Python or Shell function(s)"></i>
Task script type
</dt>
<dd>{{task.get_script_type_display}}</dd>
@@ -215,7 +215,7 @@
<dd><code>{{task.source_url}}</code></dd>
-->
<dt>
- <i class="icon-question-sign get-help" title="Task dependency chain (other tasks)"></i>
+ <i class="icon-question-sign get-help" title="Task dependency chain (i.e. other tasks)"></i>
Dependencies
</dt>
<dd>
@@ -228,7 +228,7 @@
</ul>
</dd>
<dt>
- <i class="icon-question-sign get-help" title="Which other tasks depend on this task"></i>
+ <i class="icon-question-sign get-help" title="Tasks that depend on this task"></i>
Reverse dependencies
</dt>
<dd>
@@ -248,14 +248,14 @@
<dl class="dl-horizontal">
{% if task.elapsed_time %}
<dt>
- <i class="icon-question-sign get-help" title="How long it took the task to finish, expressed in seconds"></i>
+ <i class="icon-question-sign get-help" title="How long it took the task to finish in seconds"></i>
Time (secs)
</dt>
<dd>{{task.elapsed_time|format_none_and_zero|floatformat:2}}</dd>
{% endif %}
{% if task.cpu_usage > 0 %}
<dt>
- <i class="icon-question-sign get-help" title="Task CPU utilisation, expressed as a percentage"></i>
+ <i class="icon-question-sign get-help" title="The percentage of task CPU utilization"></i>
CPU usage
</dt>
<dd>{{task.cpu_usage|format_none_and_zero|floatformat:2}}%</dd>