aboutsummaryrefslogtreecommitdiffstats
path: root/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml
diff options
context:
space:
mode:
Diffstat (limited to 'doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml')
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml20
1 files changed, 9 insertions, 11 deletions
diff --git a/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml b/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml
index e5aeffcff..ae7e4cee8 100644
--- a/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml
+++ b/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml
@@ -1142,14 +1142,14 @@
to "hide" these <filename>.bb</filename> and
<filename>.bbappend</filename> files.
BitBake ignores any recipe or recipe append files that
- match the expression.
+ match any of the expressions.
It is as if BitBake does not see them at all.
Consequently, matching files are not parsed or otherwise
used by BitBake.</para>
<para>
- The value you provide is passed to Python's regular
+ The values you provide are passed to Python's regular
expression compiler.
- The expression is compared against the full paths to
+ The expressions are compared against the full paths to
the files.
For complete syntax information, see Python's
documentation at
@@ -1165,18 +1165,16 @@
BBMASK = "meta-ti/recipes-misc/"
</literallayout>
If you want to mask out multiple directories or recipes,
- use the vertical bar to separate the regular expression
- fragments.
+ you can specify multiple regular expression fragments.
This next example masks out multiple directories and
individual recipes:
<literallayout class='monospaced'>
- BBMASK = "meta-ti/recipes-misc/|meta-ti/recipes-ti/packagegroup/"
- BBMASK .= "|.*meta-oe/recipes-support/"
- BBMASK .= "|.*openldap"
- BBMASK .= "|.*opencv"
- BBMASK .= "|.*lzma"
+ BBMASK += "/meta-ti/recipes-misc/ meta-ti/recipes-ti/packagegroup/"
+ BBMASK += "/meta-oe/recipes-support/"
+ BBMASK += "/meta-foo/.*/openldap"
+ BBMASK += "opencv.*\.bbappend"
+ BBMASK += "lzma"
</literallayout>
- Notice how the vertical bar is used to append the fragments.
<note>
When specifying a directory name, use the trailing
slash character to ensure you match just that directory