aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2018-09-25 11:07:06 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-25 23:22:54 +0100
commit8c222c45148d1f21c2390d66ddd9d3e33b397f05 (patch)
tree814d07107166a3cfd364fe09df47eb5b51040a78
parent80fe44889a858bddaca230c2d49ccabfcbc236a3 (diff)
downloadbitbake-8c222c45148d1f21c2390d66ddd9d3e33b397f05.tar.gz
lib/bb/tests/parse.py: Test case was changing chdir
The test case was changing the current directory, but was never restoring it to the original location. This causes occasional failures in later test cases. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bb/tests/parse.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/bb/tests/parse.py b/lib/bb/tests/parse.py
index 8f16ba4f4..1bc47405d 100644
--- a/lib/bb/tests/parse.py
+++ b/lib/bb/tests/parse.py
@@ -44,9 +44,13 @@ C = "3"
"""
def setUp(self):
+ self.origdir = os.getcwd()
self.d = bb.data.init()
bb.parse.siggen = bb.siggen.init(self.d)
+ def tearDown(self):
+ os.chdir(self.origdir)
+
def parsehelper(self, content, suffix = ".bb"):
f = tempfile.NamedTemporaryFile(suffix = suffix)