aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2017-04-10 08:51:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-19 10:20:12 +0100
commite9c03fbfd7b057b28645affa263cb4aebfa24b04 (patch)
tree2e816cead649f2e17895093a3c2f4b686b726b40
parent4fca9a07f2d6b0544977112672b786982d7bb8f2 (diff)
downloadbitbake-e9c03fbfd7b057b28645affa263cb4aebfa24b04.tar.gz
command.py: multiconfig support for findBestProvider
In a multiconfig environment, a tinfoil call such as tinfoil.parse_recipe("multiconfig:arduino-101-sss:gcc") can fail with an error such as: File "/data/master/poky/bitbake/lib/bb/tinfoil.py", line 373, in get_recipe_file raise bb.providers.NoProvider('Unable to find any recipe file matching "%s"' % pn) bb.providers.NoProvider: Unable to find any recipe file matching "multiconfig:arduino-101-sss:gcc" The culprit is findBestProvider, which does not handle multiconfig. This patch fixes the error and in the case mentioned above the tinfoil call returns: "multiconfig:arduino-101-sss:/data/master/poky/meta/recipes-devtools/gcc/gcc_6.3.bb" [YOCTO#11210] Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bb/command.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/lib/bb/command.py b/lib/bb/command.py
index 78a86ac4d..390d4f1de 100644
--- a/lib/bb/command.py
+++ b/lib/bb/command.py
@@ -141,6 +141,12 @@ class Command:
self.currentAsyncCommand = None
self.cooker.finishcommand()
+def split_mc_pn(pn):
+ if pn.startswith("multiconfig:"):
+ _, mc, pn = pn.split(":", 2)
+ return (mc, pn)
+ return ('', pn)
+
class CommandsSync:
"""
A class of synchronous commands
@@ -425,8 +431,8 @@ class CommandsSync:
findProviders.readonly = True
def findBestProvider(self, command, params):
- pn = params[0]
- return command.cooker.findBestProvider(pn)
+ (mc, pn) = split_mc_pn(params[0])
+ return command.cooker.findBestProvider(pn, mc)
findBestProvider.readonly = True
def allProviders(self, command, params):