summaryrefslogtreecommitdiffstats
path: root/lib/bb/__init__.py
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-04-15 08:45:15 -0700
committerChris Larson <chris_larson@mentor.com>2010-04-15 08:54:07 -0700
commitf936f1c0edf70860ea0f39ec1a500ba43b56f289 (patch)
tree42d7138b0448733bff53634a9e205105b6f5f27d /lib/bb/__init__.py
parent8f4b7b10f8740a41c085beeca5105f15204b0979 (diff)
downloadbitbake-f936f1c0edf70860ea0f39ec1a500ba43b56f289.tar.gz
Move the python version check into the python package
This ensures the check is run for anyone using the package, including setup.py, though it's sad that it's necessary, since all it really wants is __version__. Ideally, we'd avoid the version check entirely in favor of checking for functionality, but that's rather difficult with language constructs like context managers, so this'll do for now. Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'lib/bb/__init__.py')
-rw-r--r--lib/bb/__init__.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/bb/__init__.py b/lib/bb/__init__.py
index bf2f35a73..e4a970c64 100644
--- a/lib/bb/__init__.py
+++ b/lib/bb/__init__.py
@@ -23,6 +23,10 @@
__version__ = "1.11.0"
+import sys
+if sys.version_info < (2, 6, 0):
+ raise RuntimeError("Sorry, python 2.6.0 or later is required for this version of bitbake")
+
import os
import bb.msg