summaryrefslogtreecommitdiffstats
path: root/contrib/vim/ftdetect/bitbake.vim
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/vim/ftdetect/bitbake.vim')
-rw-r--r--contrib/vim/ftdetect/bitbake.vim28
1 files changed, 24 insertions, 4 deletions
diff --git a/contrib/vim/ftdetect/bitbake.vim b/contrib/vim/ftdetect/bitbake.vim
index 3882a9a08..179e4d988 100644
--- a/contrib/vim/ftdetect/bitbake.vim
+++ b/contrib/vim/ftdetect/bitbake.vim
@@ -1,4 +1,24 @@
-au BufNewFile,BufRead *.bb setfiletype bitbake
-au BufNewFile,BufRead *.bbclass setfiletype bitbake
-au BufNewFile,BufRead *.inc setfiletype bitbake
-" au BufNewFile,BufRead *.conf setfiletype bitbake
+" Vim filetype detection file
+" Language: BitBake
+" Author: Ricardo Salveti <rsalveti@rsalveti.net>
+" Copyright: Copyright (C) 2008 Ricardo Salveti <rsalveti@rsalveti.net>
+" Licence: You may redistribute this under the same terms as Vim itself
+"
+" This sets up the syntax highlighting for BitBake files, like .bb, .bbclass and .inc
+
+if &compatible || version < 600
+ finish
+endif
+
+" .bb and .bbclass
+au BufNewFile,BufRead *.b{b,bclass} set filetype=bitbake
+
+" .inc
+au BufNewFile,BufRead *.inc set filetype=bitbake
+
+" .conf
+au BufNewFile,BufRead *.conf
+ \ if (match(expand("%:p:h"), "conf") > 0) |
+ \ set filetype=bitbake |
+ \ endif
+