aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-05 13:19:57 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-05 13:19:57 +0100
commit6f1647aa9079471a2062166660ab9fb6b074817e (patch)
tree86dccf0ebf5e6818fe2342d4a068cf5171740ccb
parent46f1070d70f731f171b12e5f52c006abc9f8768b (diff)
downloadmeta-openembedded-6f1647aa.tar.gz
gcc 4.5: import http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?id=f13cb20ed19c41b9ff85ef1c9ec0883a21d1d5bf and convert to INC_PR
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--recipes-devtools/gcc/gcc-4.5.inc3
-rw-r--r--recipes-devtools/gcc/gcc-4.5/GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch33
-rw-r--r--recipes-devtools/gcc/gcc-configure-cross.inc2
-rw-r--r--recipes-devtools/gcc/gcc-configure-sdk.inc2
-rw-r--r--recipes-devtools/gcc/gcc-cross-canadian_4.5.bb4
-rw-r--r--recipes-devtools/gcc/gcc-cross-initial_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc-cross-intermediate_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc-cross_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk-initial_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc-runtime_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc_4.5.bb2
13 files changed, 48 insertions, 12 deletions
diff --git a/recipes-devtools/gcc/gcc-4.5.inc b/recipes-devtools/gcc/gcc-4.5.inc
index 3728fa0e66..ddd9f98399 100644
--- a/recipes-devtools/gcc/gcc-4.5.inc
+++ b/recipes-devtools/gcc/gcc-4.5.inc
@@ -14,6 +14,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
SRCREV = "167948"
PV = "4.5"
+INC_PR = "r11"
+
# BINV should be incremented after updating to a revision
# after a minor gcc release (e.g. 4.5.1 or 4.5.2) has been made
# the value will be minor-release+1 e.g. if minor release was
@@ -162,6 +164,7 @@ SRC_URI = "svn://gcc.gnu.org/svn/gcc/branches;module=${BRANCH} \
\
file://optional_libstdc.patch \
file://64bithack.patch \
+ file://GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch \
"
SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
diff --git a/recipes-devtools/gcc/gcc-4.5/GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch b/recipes-devtools/gcc/gcc-4.5/GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch
new file mode 100644
index 0000000000..9ae01c3fc7
--- /dev/null
+++ b/recipes-devtools/gcc/gcc-4.5/GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch
@@ -0,0 +1,33 @@
+# by default c++ include directories are not relative to "--sysroot"
+# which brings one trouble when using the toolchain in an environment
+# where the build directory generating that toolchain doesn't exist,
+# e.g. in sstate, machine specific sysroot and relocatable SDK
+# toolchain. This patch now enables c++ include paths under sysroot.
+# This way it's enough as long as "--sysroot" is correctly enabled
+# in the new environment.
+#
+# Signed-off-by Kevin Tian <kevin.tian@intel.com>, 2010-12-30
+
+diff --git a/gcc/cppdefault.c b/gcc/cppdefault.c
+index 5024f48..9b47d1c 100644
+--- a/gcc/cppdefault.c
++++ b/gcc/cppdefault.c
+@@ -48,15 +48,15 @@ const struct default_include cpp_include_defaults[]
+ = {
+ #ifdef GPLUSPLUS_INCLUDE_DIR
+ /* Pick up GNU C++ generic include files. */
+- { GPLUSPLUS_INCLUDE_DIR, "G++", 1, 1, 0, 0 },
++ { GPLUSPLUS_INCLUDE_DIR, "G++", 1, 1, 1, 0 },
+ #endif
+ #ifdef GPLUSPLUS_TOOL_INCLUDE_DIR
+ /* Pick up GNU C++ target-dependent include files. */
+- { GPLUSPLUS_TOOL_INCLUDE_DIR, "G++", 1, 1, 0, 1 },
++ { GPLUSPLUS_TOOL_INCLUDE_DIR, "G++", 1, 1, 1, 1 },
+ #endif
+ #ifdef GPLUSPLUS_BACKWARD_INCLUDE_DIR
+ /* Pick up GNU C++ backward and deprecated include files. */
+- { GPLUSPLUS_BACKWARD_INCLUDE_DIR, "G++", 1, 1, 0, 0 },
++ { GPLUSPLUS_BACKWARD_INCLUDE_DIR, "G++", 1, 1, 1, 0 },
+ #endif
+ #ifdef LOCAL_INCLUDE_DIR
+ /* /usr/local/include comes before the fixincluded header files. */
diff --git a/recipes-devtools/gcc/gcc-configure-cross.inc b/recipes-devtools/gcc/gcc-configure-cross.inc
index 3da92e24a1..04a8685358 100644
--- a/recipes-devtools/gcc/gcc-configure-cross.inc
+++ b/recipes-devtools/gcc/gcc-configure-cross.inc
@@ -5,7 +5,7 @@ USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}'
EXTRA_OECONF += " --enable-poison-system-directories "
EXTRA_OECONF_PATHS = "--with-local-prefix=${STAGING_DIR_TARGET}${target_exec_prefix} \
- --with-gxx-include-dir=${STAGING_DIR_TARGET}/${target_includedir}/c++ \
+ --with-gxx-include-dir=${target_includedir}/c++ \
--with-sysroot=${STAGING_DIR_TARGET} \
--with-build-sysroot=${STAGING_DIR_TARGET}"
diff --git a/recipes-devtools/gcc/gcc-configure-sdk.inc b/recipes-devtools/gcc/gcc-configure-sdk.inc
index 0eb33adda8..756e74e48d 100644
--- a/recipes-devtools/gcc/gcc-configure-sdk.inc
+++ b/recipes-devtools/gcc/gcc-configure-sdk.inc
@@ -5,7 +5,7 @@ USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}'
USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibcgnueabi", "no", "", d )}'
EXTRA_OECONF_PATHS = "--with-local-prefix=${SDKPATH}/sysroots/${TARGET_SYS}${target_exec_prefix} \
- --with-gxx-include-dir=${SDKPATH}/sysroots/${TARGET_SYS}${target_includedir}/c++ \
+ --with-gxx-include-dir=${target_includedir}/c++ \
--with-build-time-tools=${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/bin \
--with-sysroot=${SDKPATH}/sysroots/${TARGET_SYS} \
--with-build-sysroot=${STAGING_DIR_TARGET}"
diff --git a/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb b/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb
index 4c48b8345d..6a4cc5e985 100644
--- a/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb
+++ b/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb
@@ -5,14 +5,14 @@ require gcc-cross-canadian.inc
require gcc-configure-sdk.inc
require gcc-package-sdk.inc
-PR = "r10"
+PR = "${INC_PR}.0"
DEPENDS += "gmp-nativesdk mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
RDEPENDS_${PN} += "mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
SYSTEMHEADERS = "/usr/include"
SYSTEMLIBS = "/lib/"
-SYSTEMLIBS1 = "/usr/lib/"
+SYSTEMLIB. = "/usr/lib/"
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
--disable-libgomp --disable-libmudflap \
diff --git a/recipes-devtools/gcc/gcc-cross-initial_4.5.bb b/recipes-devtools/gcc/gcc-cross-initial_4.5.bb
index 3ce5ca0a2c..5ca9cd7a68 100644
--- a/recipes-devtools/gcc/gcc-cross-initial_4.5.bb
+++ b/recipes-devtools/gcc/gcc-cross-initial_4.5.bb
@@ -1,5 +1,5 @@
require gcc-cross_${PV}.bb
require gcc-cross-initial.inc
-PR = "r10"
+PR = "${INC_PR}.0"
diff --git a/recipes-devtools/gcc/gcc-cross-intermediate_4.5.bb b/recipes-devtools/gcc/gcc-cross-intermediate_4.5.bb
index 0fc54e2cca..aa7d148e8a 100644
--- a/recipes-devtools/gcc/gcc-cross-intermediate_4.5.bb
+++ b/recipes-devtools/gcc/gcc-cross-intermediate_4.5.bb
@@ -1,4 +1,4 @@
require gcc-cross_${PV}.bb
require gcc-cross-intermediate.inc
-PR = "r10"
+PR = "${INC_PR}.0"
diff --git a/recipes-devtools/gcc/gcc-cross_4.5.bb b/recipes-devtools/gcc/gcc-cross_4.5.bb
index d56045446e..2b7e727716 100644
--- a/recipes-devtools/gcc/gcc-cross_4.5.bb
+++ b/recipes-devtools/gcc/gcc-cross_4.5.bb
@@ -1,4 +1,4 @@
-PR = "r12"
+PR = "${INC_PR}.2"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/recipes-devtools/gcc/gcc-crosssdk-initial_4.5.bb b/recipes-devtools/gcc/gcc-crosssdk-initial_4.5.bb
index 69afbae2fc..8853e48bfb 100644
--- a/recipes-devtools/gcc/gcc-crosssdk-initial_4.5.bb
+++ b/recipes-devtools/gcc/gcc-crosssdk-initial_4.5.bb
@@ -1,4 +1,4 @@
require gcc-cross-initial_${PV}.bb
require gcc-crosssdk-initial.inc
-PR = "r10"
+PR = "${INC_PR}.0"
diff --git a/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.bb b/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.bb
index 934ae644a7..547c9570f0 100644
--- a/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.bb
+++ b/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.bb
@@ -1,4 +1,4 @@
require gcc-cross-intermediate_${PV}.bb
require gcc-crosssdk-intermediate.inc
-PR = "r10"
+PR = "${INC_PR}.0"
diff --git a/recipes-devtools/gcc/gcc-crosssdk_4.5.bb b/recipes-devtools/gcc/gcc-crosssdk_4.5.bb
index 48a68bed1a..25c000aa79 100644
--- a/recipes-devtools/gcc/gcc-crosssdk_4.5.bb
+++ b/recipes-devtools/gcc/gcc-crosssdk_4.5.bb
@@ -1,4 +1,4 @@
require gcc-cross_${PV}.bb
require gcc-crosssdk.inc
-PR = "r10"
+PR = "${INC_PR}.0"
diff --git a/recipes-devtools/gcc/gcc-runtime_4.5.bb b/recipes-devtools/gcc/gcc-runtime_4.5.bb
index fc3ab0711e..36df1d002e 100644
--- a/recipes-devtools/gcc/gcc-runtime_4.5.bb
+++ b/recipes-devtools/gcc/gcc-runtime_4.5.bb
@@ -1,4 +1,4 @@
-PR = "r10"
+PR = "${INC_PR}.0"
require gcc-${PV}.inc
require gcc-configure-runtime.inc
diff --git a/recipes-devtools/gcc/gcc_4.5.bb b/recipes-devtools/gcc/gcc_4.5.bb
index f54c3c6f50..442c273ffc 100644
--- a/recipes-devtools/gcc/gcc_4.5.bb
+++ b/recipes-devtools/gcc/gcc_4.5.bb
@@ -1,4 +1,4 @@
-PR = "r11"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc