aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-12 12:24:28 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-12 12:24:28 +0200
commit44ded83e917c4d8b47b215648efc2860f794c764 (patch)
treebc4ceaed0afc04677aafdd59d4c462953fe1ad25
parent49ddf7eeda01a541d4bb9f25d8c756ef2d81012e (diff)
downloadopenembedded-44ded83e917c4d8b47b215648efc2860f794c764.tar.gz
urjtag: added git version
added git version as git head supports jtag over gpio. Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
-rw-r--r--recipes/urjtag/urjtag_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/urjtag/urjtag_git.bb b/recipes/urjtag/urjtag_git.bb
new file mode 100644
index 0000000000..1159c1fc6f
--- /dev/null
+++ b/recipes/urjtag/urjtag_git.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "UrJTAG is a universal JTAG library, servers and tools"
+HOMEPAGE = "http://urjtag.org/"
+LICENSE = "GPLv2"
+DEPENDS = "libftdi libusb gettext readline"
+
+SRCREV = "fc8686b8dd545f54d25e77f65e43f4d774bc46"
+
+PV = "0.10"
+PR = "r0"
+PR_append = "+gitr${SRCPV}"
+
+S = "${WORKDIR}/git/urjtag"
+
+SRC_URI = "git://urjtag.git.sourceforge.net/gitroot/urjtag/urjtag;protocol=git;branch=master \
+ "
+inherit autotools
+
+# no idea why -s would make a difference but without it configure fails.
+# guess the symlink is created before the actual content is there
+EXTRA_AUTORECONF = "-s"
+
+do_install () {
+ oe_runmake DESTDIR=${D} MKINSTALLDIRS="${S}/tools/mkinstalldirs" install
+}