aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer/gst-plugins.inc
diff options
context:
space:
mode:
authorMichael Smith <msmith@cbnco.com>2010-09-23 16:49:18 -0400
committerMichael Smith <msmith@cbnco.com>2010-09-27 07:55:14 -0400
commit3d7f3a9e493b6ac454b89add37108083b5cbfa97 (patch)
treebe62e550a4031de4769912f90cb43a8da0bb5a93 /recipes/gstreamer/gst-plugins.inc
parentb64b1d26dc02014090eeea71f3f2807a48d2cddc (diff)
downloadopenembedded-3d7f3a9e493b6ac454b89add37108083b5cbfa97.tar.gz
gst-plugins.inc: fix path to orcc when prefix != /usr
Signed-off-by: Michael Smith <msmith@cbnco.com>
Diffstat (limited to 'recipes/gstreamer/gst-plugins.inc')
-rw-r--r--recipes/gstreamer/gst-plugins.inc4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes/gstreamer/gst-plugins.inc b/recipes/gstreamer/gst-plugins.inc
index 33b494b193..48fd7c3ab1 100644
--- a/recipes/gstreamer/gst-plugins.inc
+++ b/recipes/gstreamer/gst-plugins.inc
@@ -21,9 +21,11 @@ do_configure_prepend() {
sed -i -e 's:`$PKG_CONFIG --variable=includedir gstreamer-0.10`:${STAGING_INCDIR}/gstreamer-0.10:g' ${S}/configure.ac
}
+# orc.m4 calls pkg-config ----variable=orcc orc-0.4 to get the path to orcc,
+# resulting in /usr/bin/orcc. Force it to use the staged orcc.
do_configure_append() {
for i in $(find ${S} -name "Makefile") ; do
- sed -i -e s:/usr/bin/orcc:${STAGING_BINDIR_NATIVE}/orcc:g $i
+ sed -i -e s:${bindir}/orcc:${STAGING_BINDIR_NATIVE}/orcc:g $i
done
}