aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lmbench/lmbench_3.0-a9.bb
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-05-11 15:12:19 -0700
committerTom Rini <tom_rini@mentor.com>2011-05-11 15:14:54 -0700
commit48433b13bf3a26e9ccb83bf8e7344ee3e37f6139 (patch)
tree081ab785ea58fee1d28f1b861fa1e76f650aba55 /recipes/lmbench/lmbench_3.0-a9.bb
parent1259e0289ce53198cc6c57a9616c8a1623be502a (diff)
downloadopenembedded-48433b13bf3a26e9ccb83bf8e7344ee3e37f6139.tar.gz
lmbench: Rework for binaries in /usr/bin
With the move to having lmbench binaries reside in /usr/bin both the lmbench-run script we provide as well as config-run and results from lmbench no longer work, so we need to fixup the paths in a few places. While in here, call install -d once to make all the directories we need and re-order stuff to flow better. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/lmbench/lmbench_3.0-a9.bb')
-rw-r--r--recipes/lmbench/lmbench_3.0-a9.bb24
1 files changed, 12 insertions, 12 deletions
diff --git a/recipes/lmbench/lmbench_3.0-a9.bb b/recipes/lmbench/lmbench_3.0-a9.bb
index d1e9162bbe..ce6d1a80c0 100644
--- a/recipes/lmbench/lmbench_3.0-a9.bb
+++ b/recipes/lmbench/lmbench_3.0-a9.bb
@@ -3,13 +3,14 @@ DESCRIPTION = "Tools for performance analysis."
LICENSE = "GPL"
RDEPENDS_${PN} = "debianutils"
-PR = "r3"
+PR = "r4"
inherit autotools
SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
file://lmbench-run \
- file://rename-line-binary.patch"
+ file://rename-line-binary.patch \
+ file://update-results-script.patch"
SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf"
SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551"
@@ -40,24 +41,23 @@ do_compile () {
fi
install -d ${S}/bin/${TARGET_SYS}
oe_runmake -C src
- sed -i -e 's,^SHAREDIR=.*$,SHAREDIR=${datadir}/${PN},;' \
- -e 's,^BINDIR=.*$,BINDIR=${libdir}/${PN},;' ${WORKDIR}/lmbench-run
}
do_install () {
- mkdir -p ${D}${libdir}/lmbench
+ install -d ${D}${localstatedir}/run/lmbench \
+ ${D}${bindir} ${D}${mandir} ${D}${libdir}/lmbench \
+ ${D}${datadir}/lmbench/scripts
oe_runmake 'BASE=${D}${prefix}' \
-C src install
- install -d ${D}${localstatedir}/lib/lmbench/config \
- ${D}${localstatedir}/run/lmbench \
- ${D}${bindir}
- install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/
- mkdir -p ${D}${mandir}
+ mv ${D}${bindir}/line ${D}${bindir}/lm_line
mv ${D}${prefix}/man/* ${D}${mandir}/
+ install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/
+ sed -i -e 's,^SHAREDIR=.*$,SHAREDIR=${datadir}/${PN},;' \
+ -e 's,^BINDIR=.*$,BINDIR=${libdir}/${PN},;' \
+ -e 's,^CONFIG=.*$,CONFIG=$SHAREDIR/`$SCRIPTSDIR/config`,;' \
+ ${D}${bindir}/lmbench-run
install -m 0755 ${S}/scripts/lmbench ${D}${bindir}
- install -d ${D}${datadir}/lmbench/scripts
install -m 0755 ${S}/scripts/* ${D}${datadir}/lmbench/scripts
- mv ${D}${bindir}/line ${D}${bindir}/lm_line
}
FILES_${PN} += "${datadir}/lmbench"