aboutsummaryrefslogtreecommitdiffstats
path: root/org.openembedded.bc.ui/scripts
diff options
context:
space:
mode:
Diffstat (limited to 'org.openembedded.bc.ui/scripts')
-rw-r--r--org.openembedded.bc.ui/scripts/bug_install.sh24
-rw-r--r--org.openembedded.bc.ui/scripts/gumstix_install.sh68
-rw-r--r--org.openembedded.bc.ui/scripts/install_flavors.txt8
-rw-r--r--org.openembedded.bc.ui/scripts/install_script_api.txt19
-rw-r--r--org.openembedded.bc.ui/scripts/oe_dev_install.sh45
-rw-r--r--org.openembedded.bc.ui/scripts/poky_install.sh24
6 files changed, 188 insertions, 0 deletions
diff --git a/org.openembedded.bc.ui/scripts/bug_install.sh b/org.openembedded.bc.ui/scripts/bug_install.sh
new file mode 100644
index 0000000..89e97fe
--- /dev/null
+++ b/org.openembedded.bc.ui/scripts/bug_install.sh
@@ -0,0 +1,24 @@
+#!/bin/bash
+# Installation script for BUG R1.4
+# Adapted from instructions available at http://wiki.openembedded.net/index.php/Getting_started
+# This script can be executable as shell script after substituting {| |} variables with real values.
+# 4/3/2009 Ken Gilmer
+
+# These are the variables that are queried in the UI. The following lines are parsed by the install wizard.
+# {|D|Install Directory|R|${HOME}/oe||}
+# {|T|Init Script|R|reinstate-build-env||}
+
+# System Check
+which git
+which svn
+which python
+
+# Directory Setup
+[ -d ${Install Directory} ] || mkdir -p ${Install Directory}
+cd ${Install Directory}
+
+# Installing from Bug Labs SVN repository
+svn export -r HEAD svn://svn.buglabs.net/bug/tags/releases/R1.4/com.buglabs.build.oe
+mv com.buglabs.build.oe/* .
+rm -Rf com.buglabs.build.oe
+
diff --git a/org.openembedded.bc.ui/scripts/gumstix_install.sh b/org.openembedded.bc.ui/scripts/gumstix_install.sh
new file mode 100644
index 0000000..84264ba
--- /dev/null
+++ b/org.openembedded.bc.ui/scripts/gumstix_install.sh
@@ -0,0 +1,68 @@
+#!/bin/bash
+# Installation script for Gumstix build system.
+# Adapted from instructions available at http://www.gumstix.net/Setup-and-Programming/view/Overo-Setup-and-Programming/Setting-up-a-build-environment/111.html
+# This script should be executable after substituting ${} variables with real values.
+# 4/8/2010 Ken Gilmer, based on a script provided by Ash Charles
+
+# These are the variables that are queried in the UI. The following lines are parsed by the install wizard.
+# {|D|Install Directory|R|${HOME}/gumstix-oe|http://www.gumstix.net/Setup-and-Programming/view/Getting-started/Setting-up-a-build-environment/111.html|Location to install OE metadata.|}
+# {|D|Download Directory|R|${HOME}/gumstix-dl||Location to install source packages.|}
+# {|D|Build Directory|R|${HOME}/gumstix-build||Location for temporary build files.|}
+# {|D|Temp Directory|R|${HOME}/gumstix-tmp||}
+# {|T|Repository URL|R|git://gitorious.org/gumstix-oe/mainline.git org.openembedded.dev||}
+# {|C|Machine Type|R|overo,verdex||Gumstix device type.|}
+# {|T|Init Script|R|build/profile||Environment initialization script.|}
+# {|B|Configure Host|R|false||Modify the system configuration file sysctl.conf to work with OpenEmbedded.|}
+# {|B|Install Host Packages|R|false||Install required Ubunutu packages.|}
+
+which ssh-askpass
+# Installing OE Dependencies
+export SUDO_ASKPASS=`which ssh-askpass`
+test ${Install Host Packages} = true && sudo -A apt-get update
+test ${Install Host Packages} = true && sudo -A apt-get install -y git-core subversion build-essential help2man diffstat texi2html texinfo libncurses5-dev cvs gawk python-dev python-pysqlite2 unzip
+# Configuring Host Machine
+test ${Configure Host} = true && sudo -A ln -sf /bin/bash /bin/sh
+test ${Configure Host} = true && sudo -A sh -c 'echo -e "vm.vdso_enabled=0" >> /etc/sysctl.conf'
+test ${Configure Host} = true && sudo -A sh -c 'echo -e "vm.mmap_min_addr=0" >> /etc/sysctl.conf'
+test ${Configure Host} = true && sudo -A sysctl -p
+
+# Cloning OE Repository
+mkdir -p ${Install Directory}
+cd ${Install Directory}
+git clone --verbose --progress ${Repository URL}
+test ! -d org.openembedded.dev && echo "ERROR: Repository clone of ${Repository URL} failed. !!OTEWIZARDSTOP"
+
+# Configuring Machine Type
+cd org.openembedded.dev
+git checkout --track -b ${Machine Type} origin/${Machine Type}
+# Cloning Bitbake Repository
+cd ${Install Directory}
+git clone git://git.openembedded.net/bitbake bitbake
+cd bitbake
+git checkout 1.8.18
+
+cd ${Install Directory}
+
+# Setup environment
+cp -r org.openembedded.dev/contrib/gumstix/build .
+cd build/
+mv profile profile.orig
+echo '# Gumstix OE init file generated by OTE' > profile
+echo 'export BB_ENV_EXTRAWHITE="MACHINE DISTRO ANGSTROM_MODE OVEROTOP OEBRANCH USERBRANCH TITOOLSDIR"' >> profile
+echo 'export OVEROTOP="${Install Directory}"' >> profile
+echo 'export OEBRANCH="${OVEROTOP}/org.openembedded.dev"' >> profile
+echo 'export USERBRANCH="${OVEROTOP}/user.collection"' >> profile
+echo 'export PATH="${OVEROTOP}/bitbake/bin:$PATH"' >> profile
+echo 'export BBPATH="${OVEROTOP}/build:${USERBRANCH}:${OEBRANCH}"' >> profile
+echo 'export TITOOLSDIR="${OVEROTOP}/ti"' >> profile
+echo 'umask 0002' >> profile
+
+mkdir ${Install Directory}/user.collection
+
+# Fix the locations of the Download and sources directories
+cd ${Install Directory}/build/conf/
+sed 's|DL_DIR = "${OVEROTOP}/sources"|DL_DIR = "${Download Directory}"|' site.conf > site.conf2
+sed 's|TMPDIR = ${OVEROTOP}/tmp|TMPDIR = ${Temp Directory}|' site.conf2 > site.conf3
+mv site.conf site.conf.orig
+rm site.conf2
+mv site.conf3 site.conf
diff --git a/org.openembedded.bc.ui/scripts/install_flavors.txt b/org.openembedded.bc.ui/scripts/install_flavors.txt
new file mode 100644
index 0000000..a762a88
--- /dev/null
+++ b/org.openembedded.bc.ui/scripts/install_flavors.txt
@@ -0,0 +1,8 @@
+# this file describes all flavors of OE that can be installed.
+# the format is pipe delimited
+# Flavor Label (shows in UI)| description text| image URL| script URL
+OpenEmbedded - Development Branch|The main development branch of OpenEmbedded|icons/OE_logo_128.png|scripts/oe_dev_install.sh
+Bug Labs Linux R1.4|BUG Linux provides developer tools for modular hardware|icons/BUG_logo_128.png|scripts/bug_install.sh
+Poky Linux - Development Branch|Poky Linux provides a consistent and stable build environment.|icons/poky_128.png|scripts/poky_install.sh
+# BeagleBoard Linux|Beagleboard Linux is a customization of OpenEmbedded|icons/beagle_128.png|scripts/beagle_install.sh
+Gumstix Linux|The OpenEmbedded variant for Gumstix Boards, requires Debian-based Host Distro|icons/compute_gumstix.jpg|scripts/gumstix_install.sh \ No newline at end of file
diff --git a/org.openembedded.bc.ui/scripts/install_script_api.txt b/org.openembedded.bc.ui/scripts/install_script_api.txt
new file mode 100644
index 0000000..d9a4890
--- /dev/null
+++ b/org.openembedded.bc.ui/scripts/install_script_api.txt
@@ -0,0 +1,19 @@
+$[Distribution^angstrom-2008.1]
+
+
+{|Datatype|Label|UnRequired|Data|Help URL|Help Text|}
+{|T|Distribution|R|angstrom-2008.1|http://wiki.openembedded.net/index.php/Getting_started#Create_local_configuration|}
+{|C|
+
+{|D|Installation Directory|R|~/oe||}
+
+
+Datatype {
+ T: text
+ C: combo (text + combo)
+ L: list (discreet selections)
+ N: number
+ D: directory
+ F: file
+ B: checkbox (boolean)
+} \ No newline at end of file
diff --git a/org.openembedded.bc.ui/scripts/oe_dev_install.sh b/org.openembedded.bc.ui/scripts/oe_dev_install.sh
new file mode 100644
index 0000000..58e18a2
--- /dev/null
+++ b/org.openembedded.bc.ui/scripts/oe_dev_install.sh
@@ -0,0 +1,45 @@
+#!/bin/bash
+# Installation script for OpenEmbedded dev branch.
+# Adapted from instructions available at http://wiki.openembedded.net/index.php/Getting_started
+# This script should be executable after substituting ${} variables with real values.
+# 4/3/2009 Ken Gilmer
+
+# These are the variables that are queried in the UI. The following lines are parsed by the install wizard.
+# {|D|Install Directory|R|${HOME}/oe||}
+# {|D|Build Directory|R|${HOME}/oe_build||}
+# {|T|Repository URL|R|git://git.openembedded.net/openembedded||}
+# {|T|Init Script|R|init.sh||}
+# {|T|Distribution|R|angstrom-2008.1||}
+# {|T|Machine|R|om-gta01||}
+# {|T|Package Cache Directory|R|${HOME}/sources||}
+
+# System Check
+which git
+which svn
+which python
+
+# Directory Setup
+[ -d ${Install Directory} ] || mkdir -p ${Install Directory}
+cd ${Install Directory}
+mkdir -p build/conf
+[ -d ${Build Directory} ] || mkdir -p ${Build Directory}
+
+# Bitbake Setup
+wget http://download.berlios.de/bitbake/bitbake-1.8.18.tar.gz
+tar xfzv bitbake-1.8.18.tar.gz
+mv bitbake-1.8.18 bitbake
+rm bitbake-1.8.18.tar.gz
+
+
+# OpenEmbedded Setup
+git clone ${Repository URL}
+echo "BBFILES = \"${Install Directory}/openembedded/recipes/*/*.bb\"" > build/conf/local.conf
+echo "DISTRO = \"${Distribution}\"" >> build/conf/local.conf
+echo "MACHINE = \"${Machine}\"" >> build/conf/local.conf
+echo "DL_DIR = \"${Package Cache Directory}\"" >> build/conf/local.conf
+echo "TMPDIR = \"${Build Directory}\"" >> build/conf/local.conf
+
+# Environment Setup Script
+echo "export BBPATH=${Install Directory}/build:${Install Directory}/openembedded" > ${Init Script}
+echo "export PATH=${Install Directory}/bitbake/bin:$PATH" >> ${Init Script}
+chmod u+x ${Init Script}
diff --git a/org.openembedded.bc.ui/scripts/poky_install.sh b/org.openembedded.bc.ui/scripts/poky_install.sh
new file mode 100644
index 0000000..ba5bdf0
--- /dev/null
+++ b/org.openembedded.bc.ui/scripts/poky_install.sh
@@ -0,0 +1,24 @@
+#!/bin/bash
+# Installation script for Poky Pinky development branch
+# Adapted from instructions available at http://wiki.openembedded.net/index.php/Getting_started
+# This script can be executable as shell script after substituting {| |} variables with real values.
+# 4/3/2009 Ken Gilmer
+
+# These are the variables that are queried in the UI. The following lines are parsed by the install wizard.
+# {|D|Install Directory|R|${HOME}/oe||}
+# {|T|Init Script|R|poky-init-build-env||}
+
+# System Check
+which git
+which svn
+which python
+
+# Directory Setup
+[ -d ${Install Directory} ] || mkdir -p ${Install Directory}
+cd ${Install Directory}
+
+# Installing from Poky pinky branch
+svn export -r HEAD http://svn.o-hand.com/repos/poky/branches/pinky/
+mv pinky/* .
+rm -Rf pinky
+