aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2011-07-29 02:20:36 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 16:41:50 +0100
commit1c28b872cb6af4c0b208ba9cea53fe0f068fd793 (patch)
tree812be2066fc125155690868333461ec7c48d0038 /recipes-bsp
parent59405af6d030bc5b0fb7c547d1405308a80e5a79 (diff)
downloadmeta-handheld-1c28b872cb6af4c0b208ba9cea53fe0f068fd793.tar.gz
zaurus-legacy-tar: adopt necessary changes for oe-core
* fix SRC_URI and add checksums * update license * delete static binary * inherit deploy * bump PR Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb13
1 files changed, 7 insertions, 6 deletions
diff --git a/recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb b/recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb
index 86e0cc7..cc2563a 100644
--- a/recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb
+++ b/recipes-bsp/zaurus-utils/zaurus-legacy-tar.bb
@@ -1,9 +1,11 @@
DESCRIPTION = "Legacy GNU-tar to unpack hd images on install for Zaurus spitz"
-LICENSE = "GPL"
+LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://${WORKDIR}/gnu-tar;md5=34b647d6444a9a38e269c2793c7d0bf2"
-PR = "r0"
+PR = "r1"
-SRC_URI = "file://gnu-tar.gz;subdir=${BPN}-${PV}"
+SRC_URI = "http://pocketworkstation.org/files/gnu-tar.gz"
+SRC_URI[md5sum] = "0c1494335e4f33ac5712d1f72de2eff2"
+SRC_URI[sha256sum] = "68e12755957a27644ced166ef9093a44f81be6e04727f2759beef5968de41f61"
do_compile() {
:
@@ -12,13 +14,12 @@ do_compile() {
PACKAGE_ARCH = "${MACHINE_ARCH}"
PACKAGES = ""
-# package_stagefile_shell needs to run before populate_staging for packaged-staging
-addtask deploy before do_populate_sysroot after do_compile
-
COMPATIBLE_MACHINE = "spitz"
inherit deploy
+addtask deploy before do_populate_sysroot after do_compile
+
do_deploy() {
install -d ${DEPLOY_DIR_IMAGE}
install -m 0755 ${WORKDIR}/gnu-tar ${DEPLOY_DIR_IMAGE}/gnu-tar