aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-04-23 23:31:12 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-04-23 22:37:38 +0100
commitb03be8d9f50a0a6bb2dd7f4faf41548fe43c5984 (patch)
tree13907b50fa4c735b42ac8dde9b544dbcf2f05174 /recipes-bsp
parent30cebb245cf40b106affd57c96a1290b3be5591d (diff)
downloadmeta-handheld-b03be8d9f50a0a6bb2dd7f4faf41548fe43c5984.tar.gz
zaurus-installer: use linux-yocto-tiny-kexecboot kernel
* bump PR Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/zaurus-utils/zaurus-installer.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-bsp/zaurus-utils/zaurus-installer.bb b/recipes-bsp/zaurus-utils/zaurus-installer.bb
index 785836f..62f01c8 100644
--- a/recipes-bsp/zaurus-utils/zaurus-installer.bb
+++ b/recipes-bsp/zaurus-utils/zaurus-installer.bb
@@ -1,9 +1,9 @@
DESCRIPTION = "Installkit for kexecboot-kernel"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-DEPENDS = "${@base_conditional('MACHINE', 'collie', 'linux-kexecboot', 'zaurus-updater linux-kexecboot', d)}"
+DEPENDS = "${@base_conditional('MACHINE', 'collie', 'linux-yocto-tiny-kexecboot', 'zaurus-updater linux-yocto-tiny-kexecboot', d)}"
DEPENDS += "${@base_conditional('MACHINE', 'spitz', 'zaurus-legacy-tar', '', d)}"
-PR = "r6"
+PR = "r7"
INHIBIT_DEFAULT_DEPS = "1"
@@ -14,7 +14,7 @@ do_compile() {
PACKAGE_ARCH = "${MACHINE_ARCH}"
PACKAGES = ""
-COMPATIBLE_MACHINE = "(collie|poodle|c7x0|spitz|akita|tosa)"
+COMPATIBLE_MACHINE = "collie|poodle|c7x0|spitz|akita|tosa"
inherit deploy
@@ -24,7 +24,7 @@ do_deploy() {
cd ${DEPLOY_DIR_IMAGE}
rm -rf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}/
mkdir installkit-${MACHINE}/
- [ -f "${KERNEL_IMAGETYPE}-kexecboot-${MACHINE}.bin" ] && cp ${KERNEL_IMAGETYPE}-kexecboot-${MACHINE}.bin installkit-${MACHINE}/${KERNEL_IMAGETYPE}
+ [ -f "${KERNEL_IMAGETYPE}-yocto-tiny-kexecboot-${MACHINE}.bin" ] && cp ${KERNEL_IMAGETYPE}-yocto-tiny-kexecboot-${MACHINE}.bin installkit-${MACHINE}/${KERNEL_IMAGETYPE}
if [ ! "${MACHINE}" = "collie" ]; then
cp updater.sh installkit-${MACHINE}/updater.sh
fi