aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-01-19 00:52:58 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-01-25 23:28:45 +0000
commitbb8013f1bb54cd79f2975dc0ba1743dd4092ca9d (patch)
treef8f9a09ca0dbff824b8f359e5d806c9fd9162dbf /recipes-bsp
parent8234ba33d0d6451b21e6135a6bc647a556a110f1 (diff)
downloadmeta-handheld-bb8013f1bb54cd79f2975dc0ba1743dd4092ca9d.tar.gz
kexecboot-cfg: Inhibit toolchain dependencies and set better label
* Inhibit toolchain dependencies, this just creates config file * Use DISTRO-MACHINE for label, unless it is not set (e.g. OE-Core with DISTRO = ""), in which case use DISTRO_VERSION-MACHINE. Unfortunately the maximum practical length for qvga is about 24 characters so we can't make all three fit. Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb b/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
index 24dd2a4..84c1116 100644
--- a/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
+++ b/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
@@ -3,13 +3,18 @@ SECTION = "base"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PR = "r12"
+PR = "r13"
+
+INHIBIT_DEFAULT_DEPS = "1"
SRC_URI = "file://icon.xpm"
CMDLINE ?= ""
CMDLINE_DEBUG ?= "${@base_conditional('DISTRO_TYPE', 'release', 'quiet', 'debug',d)}"
+# Note: for qvga the label is currently limited to about 24 chars
+KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO', True) or d.getVar('DISTRO_VERSION', True)}-${MACHINE}"
+
do_configure_prepend () {
install -m 0644 ${WORKDIR}/icon.xpm ${S}
}
@@ -20,7 +25,7 @@ echo '# First kernel stanza.
KERNEL=/boot/${KERNEL_IMAGETYPE}
# Show this label in kexecboot menu.
-LABEL=${DISTRO}-${MACHINE}
+LABEL=${KEXECBOOT_LABEL}
#
# Append this tags to the kernel cmdline.
APPEND=${CMDLINE} ${CMDLINE_DEBUG}