aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2011-07-29 01:19:27 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 16:41:50 +0100
commitbfd71271a8e515fb2c0a1c4e9a5a35c9d0913ae6 (patch)
tree80b12d98ad9e9f7b7a87f725170b4e7b5374245d /recipes-bsp
parent134c91875222ed572e5466f117a1462697c5154a (diff)
downloadmeta-handheld-bfd71271a8e515fb2c0a1c4e9a5a35c9d0913ae6.tar.gz
zaurus-installer: adopt necessary changes for oe-core
* inherit deploy * bump PR Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/zaurus-utils/zaurus-installer.bb15
1 files changed, 8 insertions, 7 deletions
diff --git a/recipes-bsp/zaurus-utils/zaurus-installer.bb b/recipes-bsp/zaurus-utils/zaurus-installer.bb
index bc345c2..7eb8fb5 100644
--- a/recipes-bsp/zaurus-utils/zaurus-installer.bb
+++ b/recipes-bsp/zaurus-utils/zaurus-installer.bb
@@ -1,20 +1,23 @@
DESCRIPTION = "Installkit for kexecboot-kernel"
-LICENSE = "zaurus-installer"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
DEPENDS = "${@base_conditional('MACHINE', 'collie', 'linux-kexecboot', 'zaurus-updater linux-kexecboot', d)}"
DEPENDS += "${@base_conditional('MACHINE', 'spitz', 'zaurus-legacy-tar', '', d)}"
-PR = "r4"
+PR = "r5"
do_compile() {
+ :
}
PACKAGE_ARCH = "${MACHINE_ARCH}"
PACKAGES = ""
-# package_stagefile_shell need to run before populate_sysroot for packaged-staging
-addtask deploy before do_populate_sysroot after do_compile
-
COMPATIBLE_MACHINE = "(collie|poodle|c7x0|spitz|akita|tosa)"
+inherit deploy
+
+addtask deploy before do_populate_sysroot after do_compile
+
do_deploy() {
cd ${DEPLOY_DIR_IMAGE}
rm -rf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}/
@@ -29,6 +32,4 @@ do_deploy() {
tar czf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz installkit-${MACHINE}/
md5sum ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz > ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz.md5
rm -rf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}/
- package_stagefile_shell ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz
- package_stagefile_shell ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz.md5
}