aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-03-18 00:13:55 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-03-25 23:51:03 +0100
commit1a1d50a1bf39136a8c974022d63e0f119f23bbff (patch)
treea1548efa155ae9c0e533fb5365194c2f666ed812 /recipes-bsp
parent4d5ecea18f2aed24c60325dbbcb413b91cfad5bf (diff)
downloadmeta-handheld-1a1d50a1bf39136a8c974022d63e0f119f23bbff.tar.gz
keymaps: edit script to reuse 2.6 kernel keymaps
* The keymap.sh script installed by oe-core recipe has a check * for KERNEL_MAJMIN=`uname -r | cut -d '.' -f 1,2` * so the keymaps-2.6.map's are ignored when running 3.x kernels * Thus, we replace the suffix of the runtime kernel with "2.6" in the .bbappend. * Bump PR Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/keymaps/keymaps_1.0.bbappend7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-bsp/keymaps/keymaps_1.0.bbappend b/recipes-bsp/keymaps/keymaps_1.0.bbappend
index d3310c1..039b30c 100644
--- a/recipes-bsp/keymaps/keymaps_1.0.bbappend
+++ b/recipes-bsp/keymaps/keymaps_1.0.bbappend
@@ -1,4 +1,4 @@
-PRINC = "1"
+PRINC = "2"
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
@@ -20,6 +20,11 @@ SRC_URI_append_jornada6xx = " file://keymap-uk-620-660.map \
file://keymap-uk.map \
"
+# we still use keymap-2.6.map files
+do_configure_append () {
+ sed -i -e 's/KERNEL_MAJMIN=.*$/KERNEL_MAJMIN="2.6"/' ${WORKDIR}/keymap.sh
+}
+
do_install_append () {
case ${MACHINE} in
c7x0 | tosa | akita | spitz | collie | poodle | h2200 | h4000 | hx4700 | jornada6xx )