aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-02-21 00:23:23 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-02-23 00:47:52 +0000
commitcc470fff8e5810850f2a58ccbf21eb9e72e7bbbe (patch)
tree7668c7bb90cbfa4bdd96c3660e50c5c162039141 /recipes-bsp
parent01f3e2c1be8f7e8a3b5c417a4e1a48c79dbf69dd (diff)
downloadmeta-handheld-cc470fff8e5810850f2a58ccbf21eb9e72e7bbbe.tar.gz
meta-handheld: recipe moved to meta-initramfs, add bbappends
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/kexecboot/kexecboot-cfg/icon.xpm43
-rw-r--r--recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb61
-rw-r--r--recipes-bsp/kexecboot/kexecboot-handhelds.inc6
-rw-r--r--recipes-bsp/kexecboot/kexecboot-klibc_git.bb12
-rw-r--r--recipes-bsp/kexecboot/kexecboot-klibc_git.bbappend3
-rw-r--r--recipes-bsp/kexecboot/kexecboot.inc62
-rw-r--r--recipes-bsp/kexecboot/kexecboot_git.bb9
-rw-r--r--recipes-bsp/kexecboot/kexecboot_git.bbappend3
8 files changed, 12 insertions, 187 deletions
diff --git a/recipes-bsp/kexecboot/kexecboot-cfg/icon.xpm b/recipes-bsp/kexecboot/kexecboot-cfg/icon.xpm
deleted file mode 100644
index 6e6fd77..0000000
--- a/recipes-bsp/kexecboot/kexecboot-cfg/icon.xpm
+++ /dev/null
@@ -1,43 +0,0 @@
-/* XPM */
-static char * icon_xpm[] = {
-"32 32 8 1",
-" c None",
-". c #D6DBDE",
-"+ c #9BA6AE",
-"@ c #60727D",
-"# c #B8BFC5",
-"$ c #A9E8F6",
-"% c #12BCE4",
-"& c #57D2EC",
-" ",
-" ",
-" ",
-" .++@@@@++. ",
-" +@@@@@@@@@@@@+ ",
-" #@@@@@@@@@@@@@@@@# ",
-" +@@@@@@@@@@@@@@@@@@+ ",
-" .@@@@@@@@++##+@@@@@@@@@. ",
-" @@@@@@@. .@@@@@@@ ",
-" +@@@@@+ $$$$ #@@@@@+ ",
-" #@@@@@. $%%%%%%%%$ .@@@@@# ",
-" @@@@@. &%%%%%%%%%%& .@@@@@ ",
-" #@@@@+ %%%%%%%%%%%%%% +@@@@# ",
-" @@@@@ &%%%%%%%%%%%%%%& @@@@@ ",
-".@@@@. $%%%%%& $%%%%%& .@@@@.",
-"+@@@@ %%%%% $%%%%%& @@@@+",
-"+@@@+ %%%%$ $%%%%%& $$ +@@@+",
-"@@@@+ $%%%% $%%%%%& $%$ +@@@@",
-"@@@@# &%%%& &%%%%& $%%& #@@@@",
-"@@@@. &%%%& %%%%& $%%%& .@@@@",
-"@@@@# $%%%& &%%& &%%%$ #@@@@",
-"+@@@+ $%%%% %%%%$ +@@@+",
-"+@@@@ %%%%& &%%%% @@@@+",
-"#@@@@ &%%%%& &%%%%& @@@@#",
-" @@@@+ %%%%%%&$$&%%%%%% +@@@@ ",
-" +@@@@. $%%%%%%%%%%%%%%$ .@@@@+ ",
-" .@@@@@ $%%%%%%%%%%%%$ @@@@@. ",
-" #++++. &%%%%%%%%& .++++# ",
-" $&&%%&&$ ",
-" ",
-" ",
-" "};
diff --git a/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb b/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
deleted file mode 100644
index 84c1116..0000000
--- a/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
+++ /dev/null
@@ -1,61 +0,0 @@
-DESCRIPTION = "Configuration file for kexecboot"
-SECTION = "base"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-
-PR = "r13"
-
-INHIBIT_DEFAULT_DEPS = "1"
-
-SRC_URI = "file://icon.xpm"
-
-CMDLINE ?= ""
-CMDLINE_DEBUG ?= "${@base_conditional('DISTRO_TYPE', 'release', 'quiet', 'debug',d)}"
-
-# Note: for qvga the label is currently limited to about 24 chars
-KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO', True) or d.getVar('DISTRO_VERSION', True)}-${MACHINE}"
-
-do_configure_prepend () {
- install -m 0644 ${WORKDIR}/icon.xpm ${S}
-}
-
-do_install_prepend () {
-echo '# First kernel stanza.
-# Specify full kernel path on target.
-KERNEL=/boot/${KERNEL_IMAGETYPE}
-
-# Show this label in kexecboot menu.
-LABEL=${KEXECBOOT_LABEL}
-#
-# Append this tags to the kernel cmdline.
-APPEND=${CMDLINE} ${CMDLINE_DEBUG}
-#
-# Specify optional initrd/initramfs.
-# INITRD=/boot/initramfs.cpio.gz
-#
-# Specify full path for a custom icon for the menu-item.
-# If not set, use device-icons as default (NAND, SD, CF, ...).
-# ICON=/boot/icon.xpm
-#
-# Priority of item in kexecboot menu.
-# Items with highest priority will be shown at top of menu.
-# Default: 0 (lowest, ordered by device ordering)
-# PRIORITY=10
-#
-#
-# Second kernel stanza.
-# KERNEL=/boot/${KERNEL_IMAGETYPE}-test
-# LABEL=${DISTRO}-${MACHINE}-test
-# APPEND=${CMDLINE}
-#' >> ${S}/boot.cfg
-}
-
-do_install () {
- install -d ${D}/boot
- install -m 0644 boot.cfg ${D}/boot/boot.cfg
- install -m 0644 icon.xpm ${D}/boot/icon.xpm
-}
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-FILES_${PN} += "/boot/*"
diff --git a/recipes-bsp/kexecboot/kexecboot-handhelds.inc b/recipes-bsp/kexecboot/kexecboot-handhelds.inc
new file mode 100644
index 0000000..ab3deca
--- /dev/null
+++ b/recipes-bsp/kexecboot/kexecboot-handhelds.inc
@@ -0,0 +1,6 @@
+EXTRA_OECONF_akita = "--enable-zaurus --enable-delay=2 --enable-evdev-rate=1000,250 --enable-fbui-width=480"
+EXTRA_OECONF_c7x0 = "--enable-zaurus --enable-delay=2 --enable-evdev-rate=1000,250 --enable-fbui-width=480"
+EXTRA_OECONF_spitz = "--enable-zaurus --enable-delay=3 --enable-evdev-rate=1000,250 --enable-fbui-width=480"
+EXTRA_OECONF_poodle = "--enable-zaurus --enable-delay=2 --enable-evdev-rate=1000,250"
+EXTRA_OECONF_tosa = "--enable-zaurus --enable-delay=2 --enable-evdev-rate=1000,250"
+EXTRA_OECONF_collie = "--enable-delay=2 --enable-evdev-rate=1000,250"
diff --git a/recipes-bsp/kexecboot/kexecboot-klibc_git.bb b/recipes-bsp/kexecboot/kexecboot-klibc_git.bb
deleted file mode 100644
index 0d6d00f..0000000
--- a/recipes-bsp/kexecboot/kexecboot-klibc_git.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-RDEPENDS_${PN} = "kexec-klibc"
-PV = "0.5.9"
-PR = "r8+gitr${SRCREV}"
-
-SRC_URI = "git://git.linuxtogo.org/home/groups/kexecboot/kexecboot.git;protocol=git "
-SRCREV = "8f1d3cc3d9c650c6a6c88f83071185d6ee0ef9c7"
-S = "${WORKDIR}/git"
-
-# the binary is statically linked against klibc
-inherit klibc
-
-require kexecboot.inc
diff --git a/recipes-bsp/kexecboot/kexecboot-klibc_git.bbappend b/recipes-bsp/kexecboot/kexecboot-klibc_git.bbappend
new file mode 100644
index 0000000..61ba802
--- /dev/null
+++ b/recipes-bsp/kexecboot/kexecboot-klibc_git.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+require kexecboot-handhelds.inc
diff --git a/recipes-bsp/kexecboot/kexecboot.inc b/recipes-bsp/kexecboot/kexecboot.inc
deleted file mode 100644
index 3a7fd9f..0000000
--- a/recipes-bsp/kexecboot/kexecboot.inc
+++ /dev/null
@@ -1,62 +0,0 @@
-###########################
-# Configure options:
-#
-# --enable-static-linking compile kexecboot as static executable [default=no]
-# --enable-fbui support framebuffer menu [default=yes]
-# --enable-fbui-width limit FB UI width to specified value [default=no]
-# --enable-fbui-height limit FB UI height to specified value [default=no]
-# --enable-textui support console text user interface [default=no]
-# --enable-cfgfiles support config files [default=yes]
-# --enable-icons support custom icons (depends on fbui) [default=yes]
-# --enable-zaurus compile Sharp Zaurus specific code [default=no]
-# --enable-zimage compile with zImage support [default=yes]
-# --enable-uimage compile with uImage support [default=no]
-# --enable-machine-kernel look for machine-specific zImage kernel [default=no]
-# --enable-devices-recreating
-# enable devices re-creating [default=yes]
-# --enable-debug enable debug output [default=no]
-# --enable-host-debug allow for non-destructive executing of kexecboot on
-# host system [default=no]
-# --enable-numkeys enable menu item selection by keys [0-9] [default=yes]
-# --enable-bg-buffer enable buffer for pre-drawed FB GUI background
-#
-# --enable-timeout allow to boot 1st kernel after timeout in seconds
-# [default=no]
-# --enable-delay specify delay before device scanning, allowing
-# initialization of old CF/SD cards [default=1]
-# --enable-bpp enable support of specified bpp modes
-# (all,32,24,18,16,4,2,1) [default=all]
-# --enable-evdev-rate change evdev (keyboard/mouse) repeat rate
-# in milliseconds e.g. "1000,250" [default=no]
-# --with-kexec-binary look for kexec binary at path
-# [default="/usr/sbin/kexec"]
-##########################
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-inherit autotools
-
-#
-# Zaurus clamshells looks better at 480x480
-
-EXTRA_OECONF_akita = "--enable-zaurus --enable-delay=2 --enable-evdev-rate=1000,250 --enable-fbui-width=480"
-EXTRA_OECONF_c7x0 = "--enable-zaurus --enable-delay=2 --enable-evdev-rate=1000,250 --enable-fbui-width=480"
-EXTRA_OECONF_spitz = "--enable-zaurus --enable-delay=3 --enable-evdev-rate=1000,250 --enable-fbui-width=480"
-EXTRA_OECONF_poodle = "--enable-zaurus --enable-delay=2 --enable-evdev-rate=1000,250"
-EXTRA_OECONF_tosa = "--enable-zaurus --enable-delay=2 --enable-evdev-rate=1000,250"
-EXTRA_OECONF_collie = "--enable-delay=2 --enable-evdev-rate=1000,250"
-
-do_install () {
- install -d ${D}${bindir}
- install -m 0755 kexecboot ${D}${bindir}/
- install -d ${D}/proc
- install -d ${D}/mnt
- install -d ${D}/dev
-}
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev"
-
-pkg_postinst_${PN} () {
- ln -sf ${bindir}/kexecboot $D/init
-}
diff --git a/recipes-bsp/kexecboot/kexecboot_git.bb b/recipes-bsp/kexecboot/kexecboot_git.bb
deleted file mode 100644
index 1341461..0000000
--- a/recipes-bsp/kexecboot/kexecboot_git.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-RDEPENDS_${PN} = "kexec"
-PV = "0.5.9"
-PR = "r8+gitr${SRCREV}"
-
-SRC_URI = "git://git.linuxtogo.org/home/groups/kexecboot/kexecboot.git;protocol=git "
-SRCREV = "8f1d3cc3d9c650c6a6c88f83071185d6ee0ef9c7"
-S = "${WORKDIR}/git"
-
-require kexecboot.inc
diff --git a/recipes-bsp/kexecboot/kexecboot_git.bbappend b/recipes-bsp/kexecboot/kexecboot_git.bbappend
new file mode 100644
index 0000000..61ba802
--- /dev/null
+++ b/recipes-bsp/kexecboot/kexecboot_git.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+require kexecboot-handhelds.inc