aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-05-21 19:16:49 -0700
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-05-22 12:13:13 +0100
commit45e4171a3dacb39ea7a4bce547edba724a520b6a (patch)
tree67a94ace7f724ac42b981ab43e244fe0f88419d8 /recipes-bsp
parent8a120feba14249321ad51829f281180f3b62e041 (diff)
downloadmeta-handheld-45e4171a3dacb39ea7a4bce547edba724a520b6a.tar.gz
ezxd: Add LIC_FILES_CHKSUM to recipe and -fPIC to CFLAGS
This recipe has been failing to build. With this patch it now builds. build tested for beaglebone Signed-off-by: Khem Raj <raj.khem@gmail.com> CC: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ezx/ezxd_svn.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-bsp/ezx/ezxd_svn.bb b/recipes-bsp/ezx/ezxd_svn.bb
index 6dbcd0f..7b69454 100644
--- a/recipes-bsp/ezx/ezxd_svn.bb
+++ b/recipes-bsp/ezx/ezxd_svn.bb
@@ -1,12 +1,12 @@
DESCRIPTION = "Open implementation of motorola's tapisrv, replaces opentapi"
-LICENSE = "GPLv2"
+LICENSE = "GPLv2+"
SECTION = "devel"
AUTHOR = "Daniel Ribeiro"
SRCREV = "2513"
PV = "0.0+svnr${SRCPV}"
PR = "r4"
-
+LIC_FILES_CHKSUM = "file://plugin.c;endline=19;md5=16da36fbb577507b411368f133ce2067"
SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=ezxd;protocol=http \
file://ezxd.init \
"
@@ -18,9 +18,9 @@ INITSCRIPT_PARAMS = "start 00 S ."
S = "${WORKDIR}/${PN}"
-CFLAGS_append = " -DDEBUG "
+CFLAGS_append = " -DDEBUG -fPIC "
-TARGET_CC_ARCH += "${LDFLAGS}"
+TARGET_CC_ARCH += "${LDFLAGS} -fPIC"
do_configure() {
# Comment out both CC and CROSS definitions