aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorPaul Eggleton <bluelightning@bluelightning.org>2012-01-09 01:06:21 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-01-22 23:16:41 +0000
commit5b4b4b012fe701597d0de803e7fa2d0ef5e59f2b (patch)
treeca32459a3e0be222c3b0b271c335bf1ab21fd37e /recipes-core
parent7469f0737aaefafd513f760b6847c29140027bc6 (diff)
downloadmeta-handheld-5b4b4b012fe701597d0de803e7fa2d0ef5e59f2b.tar.gz
udev: add modified touchscreen.rules
This adds an appropriate udev rule for h1940 iPAQs with recent kernels. Signed-off-by: Paul Eggleton <bluelightning@bluelightning.org>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/udev/udev/touchscreen.rules21
-rw-r--r--recipes-core/udev/udev_173.bbappend5
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes-core/udev/udev/touchscreen.rules b/recipes-core/udev/udev/touchscreen.rules
new file mode 100644
index 0000000..b2307cf
--- /dev/null
+++ b/recipes-core/udev/udev/touchscreen.rules
@@ -0,0 +1,21 @@
+# There are a number of modifiers that are allowed to be used in some
+# of the different fields. They provide the following subsitutions:
+#
+# %n the "kernel number" of the device.
+# For example, 'sda3' has a "kernel number" of '3'
+# %e the smallest number for that name which does not matches an existing node
+# %k the kernel name for the device
+# %M the kernel major number for the device
+# %m the kernel minor number for the device
+# %b the bus id for the device
+# %c the string returned by the PROGRAM
+# %s{filename} the content of a sysfs attribute
+# %% the '%' char itself
+#
+
+# Create a symlink to any touchscreen input device
+SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="input:*-e0*,3,*a0,1,*18,*", SYMLINK+="input/touchscreen0"
+SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="ads7846", SYMLINK+="input/touchscreen0"
+# This one is necessary for h1940
+SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="input:*-e0*,3,*a0,1,*", SYMLINK+="input/touchscreen0"
+
diff --git a/recipes-core/udev/udev_173.bbappend b/recipes-core/udev/udev_173.bbappend
new file mode 100644
index 0000000..4770c5b
--- /dev/null
+++ b/recipes-core/udev/udev_173.bbappend
@@ -0,0 +1,5 @@
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+PRINC = "1"
+