aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-xserver
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2011-10-12 11:24:21 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-10-16 11:52:40 +0100
commite392fb2c084115aecd7befcdf31de57a8ea864db (patch)
tree74fdbe3adc89fe91fa3ba776ac590265ef4f0dbd /recipes-graphics/xorg-xserver
parentb4c1268763f3d4f0f9b4326d6fa27ba9c03aeaae (diff)
downloadmeta-handheld-e392fb2c084115aecd7befcdf31de57a8ea864db.tar.gz
xserver-xf86-config: add bbappend and spitz xorg.conf
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-graphics/xorg-xserver')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/spitz/xorg.conf49
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend1
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/spitz/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/spitz/xorg.conf
new file mode 100644
index 0000000..224df5c
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/spitz/xorg.conf
@@ -0,0 +1,49 @@
+Section "Device"
+ Identifier "Generic Video Card"
+ Driver "fbdev"
+ Option "UseFBDev" "true"
+ Option "Rotate" "CW"
+EndSection
+
+Section "Monitor"
+ Identifier "Generic Monitor"
+ Option "DPMS"
+ HorizSync 28-32
+ VertRefresh 43-60
+EndSection
+
+Section "Screen"
+ Identifier "Default Screen"
+ Device "Generic Video Card"
+ Monitor "Generic Monitor"
+ DefaultDepth 16
+ SubSection "Display"
+ Depth 1
+ Modes "640x480"
+ EndSubSection
+ SubSection "Display"
+ Depth 4
+ Modes "640x480"
+ EndSubSection
+ SubSection "Display"
+ Depth 8
+ Modes "640x480"
+ EndSubSection
+ SubSection "Display"
+ Depth 15
+ Modes "640x480"
+ EndSubSection
+ SubSection "Display"
+ Depth 16
+ Modes "640x480"
+ EndSubSection
+ SubSection "Display"
+ Depth 24
+ Modes "640x480"
+ EndSubSection
+EndSection
+
+Section "ServerLayout"
+ Identifier "Default Layout"
+ Screen "Default Screen"
+EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 0000000..72d991c
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"