aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-03-23 01:27:14 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-03-25 23:47:53 +0100
commit4e5e71a4b5f12cdb3af18cd5357355a7237f4c86 (patch)
treec02e96cf194a741afb6a58167f63ca8f0fab0d14 /recipes-kernel
parentf2904e00c9c709d1f40e4a93f0f552f882bacf4f (diff)
downloadmeta-handheld-4e5e71a4b5f12cdb3af18cd5357355a7237f4c86.tar.gz
linux-handhelds-2.6: restore to working order
* Fix SRC_URI - handhelds.org CVS is long gone * Add SRC_URI checksums * Fix Makefile for current versions of make * Use FILESEXTRAPATHS instead of FILESPATHPKG * Add LIC_FILES_CHKSUM Tested on h2200. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-handhelds-2.6-2.6.21/makefile-implicit.patch34
-rw-r--r--recipes-kernel/linux/linux-handhelds-2.6.inc1
-rw-r--r--recipes-kernel/linux/linux-handhelds-2.6_2.6.21-hh20.bb11
3 files changed, 43 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-handhelds-2.6-2.6.21/makefile-implicit.patch b/recipes-kernel/linux/linux-handhelds-2.6-2.6.21/makefile-implicit.patch
new file mode 100644
index 0000000..ec69b66
--- /dev/null
+++ b/recipes-kernel/linux/linux-handhelds-2.6-2.6.21/makefile-implicit.patch
@@ -0,0 +1,34 @@
+Fix makefile for newer make versions
+
+The current version of make doesn't like mixing implicit and normal
+rules, so split these into two parts.
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+--- kernel26.orig/Makefile
++++ kernel26/Makefile
+@@ -412,7 +412,11 @@ ifeq ($(config-targets),1)
+ include $(srctree)/arch/$(ARCH)/Makefile
+ export KBUILD_DEFCONFIG
+
+-config %config: scripts_basic outputmakefile FORCE
++config: scripts_basic outputmakefile FORCE
++ $(Q)mkdir -p include/linux include/config
++ $(Q)$(MAKE) $(build)=scripts/kconfig $@
++
++%config: scripts_basic outputmakefile FORCE
+ $(Q)mkdir -p include/linux include/config
+ $(Q)$(MAKE) $(build)=scripts/kconfig $@
+
+@@ -1438,7 +1442,10 @@ endif
+ $(Q)$(MAKE) $(build)=$(build-dir) $(target-dir)$(notdir $@)
+
+ # Modules
+-/ %/: prepare scripts FORCE
++/: prepare scripts FORCE
++ $(Q)$(MAKE) KBUILD_MODULES=$(if $(CONFIG_MODULES),1) \
++ $(build)=$(build-dir)
++%/: prepare scripts FORCE
+ $(Q)$(MAKE) KBUILD_MODULES=$(if $(CONFIG_MODULES),1) \
+ $(build)=$(build-dir)
+ %.ko: prepare scripts FORCE
diff --git a/recipes-kernel/linux/linux-handhelds-2.6.inc b/recipes-kernel/linux/linux-handhelds-2.6.inc
index acd1ee0..d92e324 100644
--- a/recipes-kernel/linux/linux-handhelds-2.6.inc
+++ b/recipes-kernel/linux/linux-handhelds-2.6.inc
@@ -71,6 +71,7 @@ do_deploy_append() {
#reflash.ctl is required to reflash using bootldr
# format:
# name file md5sumfile destination
+ mkdir -p ${DEPLOY_DIR_IMAGE}
echo "${MACHINE}-kernel-${DATETIME} ${KERNEL_IMAGE_BASE_NAME} - kernel" >> ${DEPLOY_DIR_IMAGE}/reflash.ctl
gen_haret_startup
diff --git a/recipes-kernel/linux/linux-handhelds-2.6_2.6.21-hh20.bb b/recipes-kernel/linux/linux-handhelds-2.6_2.6.21-hh20.bb
index f0aa26a..ddaf055 100644
--- a/recipes-kernel/linux/linux-handhelds-2.6_2.6.21-hh20.bb
+++ b/recipes-kernel/linux/linux-handhelds-2.6_2.6.21-hh20.bb
@@ -1,19 +1,22 @@
SECTION = "kernel"
DESCRIPTION = "handhelds.org Linux kernel 2.6 for PocketPCs and other consumer handheld devices."
LICENSE = "GPLv2"
-PR = "r26"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
+
+PR = "r27"
DEFAULT_PREFERENCE = "-1"
# Override where to look for defconfigs and patches,
# we have per-kernel-release sets.
-FILESPATHPKG =. "linux-handhelds-2.6-2.6.21/${MACHINE}:linux-handhelds-2.6-2.6.21:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux-handhelds-2.6-2.6.21:"
-SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
+SRC_URI = "http://sources.openembedded.org/linux.kernel26_anoncvs.handhelds.org_K2-6-21-hh20_.tar.gz;name=kernelsrc \
file://linux-2.6.git-9d20fdd58e74d4d26dc5216efaaa0f800c23dd3a.patch \
http://www.rpsys.net/openzaurus/patches/archive/export_atags-r0a.patch;name=rppatch35 \
file://gcc4x-limits.patch \
file://0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch \
+ file://makefile-implicit.patch \
file://defconfig"
require linux-handhelds-2.6.inc
@@ -21,3 +24,5 @@ require linux-handhelds-2.6.inc
# ${RPSRC}/export_atags-r0a.patch;status=pending;name=rppatch35 \
SRC_URI[rppatch35.md5sum] = "8ab51e8ff728f4155db64b9bb6ea6d71"
SRC_URI[rppatch35.sha256sum] = "75d4c6ddbfc5e4fff7690a3308e2574f89a0e2709fb91caccb29067a9dad251a"
+SRC_URI[kernelsrc.md5sum] = "1098aed5ccce21d880d98b4ed71b9bcd"
+SRC_URI[kernelsrc.sha256sum] = "033abe5cc3350ff3627ce2cb8cb9d1a5067823f3c196b3b90d6b428d8e9d4f4b"