aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-04-09 22:05:35 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-04-09 23:30:39 +0100
commitb8cf27ca877d0574637fe2849f693e6229488757 (patch)
tree66013524a904b82114839905af729c5815415c63 /recipes-kernel
parent770a14fa7cad8622a30271cf950bd490de0411bd (diff)
downloadmeta-handheld-b8cf27ca877d0574637fe2849f693e6229488757.tar.gz
linux(kexecboot)_3.2: add CC_OPTIMIZE_FOR_SIZE=y
* to Zaurus kernels * bump PR Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-3.2/akita/defconfig1
-rw-r--r--recipes-kernel/linux/linux-3.2/c7x0/defconfig1
-rw-r--r--recipes-kernel/linux/linux-3.2/collie/defconfig1
-rw-r--r--recipes-kernel/linux/linux-3.2/poodle/defconfig1
-rw-r--r--recipes-kernel/linux/linux-3.2/spitz/defconfig1
-rw-r--r--recipes-kernel/linux/linux-3.2/tosa/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot-3.2/akita/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot-3.2/c7x0/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot-3.2/collie/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot-3.2/poodle/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot-3.2/spitz/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot-3.2/tosa/defconfig1
-rw-r--r--recipes-kernel/linux/linux-kexecboot_3.2.bbappend1
-rw-r--r--recipes-kernel/linux/linux_3.2.bb2
14 files changed, 14 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-3.2/akita/defconfig b/recipes-kernel/linux/linux-3.2/akita/defconfig
index 8e9ce4f..96f0b58 100644
--- a/recipes-kernel/linux/linux-3.2/akita/defconfig
+++ b/recipes-kernel/linux/linux-3.2/akita/defconfig
@@ -11,6 +11,7 @@ CONFIG_BLK_DEV_INITRD=y
CONFIG_RD_BZIP2=y
CONFIG_RD_LZMA=y
CONFIG_RD_LZO=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
CONFIG_SLOB=y
CONFIG_PROFILING=y
diff --git a/recipes-kernel/linux/linux-3.2/c7x0/defconfig b/recipes-kernel/linux/linux-3.2/c7x0/defconfig
index 20d4399..92d69f4 100644
--- a/recipes-kernel/linux/linux-3.2/c7x0/defconfig
+++ b/recipes-kernel/linux/linux-3.2/c7x0/defconfig
@@ -11,6 +11,7 @@ CONFIG_BLK_DEV_INITRD=y
CONFIG_RD_BZIP2=y
CONFIG_RD_LZMA=y
CONFIG_RD_LZO=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
CONFIG_SLOB=y
CONFIG_PROFILING=y
diff --git a/recipes-kernel/linux/linux-3.2/collie/defconfig b/recipes-kernel/linux/linux-3.2/collie/defconfig
index 0bc9633..3cc4642 100644
--- a/recipes-kernel/linux/linux-3.2/collie/defconfig
+++ b/recipes-kernel/linux/linux-3.2/collie/defconfig
@@ -12,6 +12,7 @@ CONFIG_BLK_DEV_INITRD=y
CONFIG_RD_BZIP2=y
CONFIG_RD_LZMA=y
CONFIG_RD_LZO=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
CONFIG_SLOB=y
CONFIG_PROFILING=y
diff --git a/recipes-kernel/linux/linux-3.2/poodle/defconfig b/recipes-kernel/linux/linux-3.2/poodle/defconfig
index 27729af..0b03dda 100644
--- a/recipes-kernel/linux/linux-3.2/poodle/defconfig
+++ b/recipes-kernel/linux/linux-3.2/poodle/defconfig
@@ -11,6 +11,7 @@ CONFIG_BLK_DEV_INITRD=y
CONFIG_RD_BZIP2=y
CONFIG_RD_LZMA=y
CONFIG_RD_LZO=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
CONFIG_SLOB=y
CONFIG_PROFILING=y
diff --git a/recipes-kernel/linux/linux-3.2/spitz/defconfig b/recipes-kernel/linux/linux-3.2/spitz/defconfig
index f2e32de..dd790e3 100644
--- a/recipes-kernel/linux/linux-3.2/spitz/defconfig
+++ b/recipes-kernel/linux/linux-3.2/spitz/defconfig
@@ -11,6 +11,7 @@ CONFIG_BLK_DEV_INITRD=y
CONFIG_RD_BZIP2=y
CONFIG_RD_LZMA=y
CONFIG_RD_LZO=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
CONFIG_SLOB=y
CONFIG_PROFILING=y
diff --git a/recipes-kernel/linux/linux-3.2/tosa/defconfig b/recipes-kernel/linux/linux-3.2/tosa/defconfig
index 8ce424b..b01a366 100644
--- a/recipes-kernel/linux/linux-3.2/tosa/defconfig
+++ b/recipes-kernel/linux/linux-3.2/tosa/defconfig
@@ -11,6 +11,7 @@ CONFIG_BLK_DEV_INITRD=y
CONFIG_RD_BZIP2=y
CONFIG_RD_LZMA=y
CONFIG_RD_LZO=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EMBEDDED=y
CONFIG_SLOB=y
CONFIG_PROFILING=y
diff --git a/recipes-kernel/linux/linux-kexecboot-3.2/akita/defconfig b/recipes-kernel/linux/linux-kexecboot-3.2/akita/defconfig
index a25331b..bd7ab1c 100644
--- a/recipes-kernel/linux/linux-kexecboot-3.2/akita/defconfig
+++ b/recipes-kernel/linux/linux-kexecboot-3.2/akita/defconfig
@@ -6,6 +6,7 @@ CONFIG_LOG_BUF_SHIFT=14
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE="initramfs.cpio.lzma"
CONFIG_RD_LZMA=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_INITRAMFS_COMPRESSION_LZMA=y
# CONFIG_UID16 is not set
# CONFIG_KALLSYMS is not set
diff --git a/recipes-kernel/linux/linux-kexecboot-3.2/c7x0/defconfig b/recipes-kernel/linux/linux-kexecboot-3.2/c7x0/defconfig
index d869fdd..4d6a4c7 100644
--- a/recipes-kernel/linux/linux-kexecboot-3.2/c7x0/defconfig
+++ b/recipes-kernel/linux/linux-kexecboot-3.2/c7x0/defconfig
@@ -6,6 +6,7 @@ CONFIG_LOG_BUF_SHIFT=14
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE="initramfs.cpio.lzma"
CONFIG_RD_LZMA=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_INITRAMFS_COMPRESSION_LZMA=y
# CONFIG_UID16 is not set
# CONFIG_KALLSYMS is not set
diff --git a/recipes-kernel/linux/linux-kexecboot-3.2/collie/defconfig b/recipes-kernel/linux/linux-kexecboot-3.2/collie/defconfig
index b690f25..cf50716 100644
--- a/recipes-kernel/linux/linux-kexecboot-3.2/collie/defconfig
+++ b/recipes-kernel/linux/linux-kexecboot-3.2/collie/defconfig
@@ -6,6 +6,7 @@ CONFIG_LOG_BUF_SHIFT=14
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE="initramfs.cpio.lzma"
CONFIG_RD_LZMA=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_INITRAMFS_COMPRESSION_LZMA=y
# CONFIG_UID16 is not set
# CONFIG_KALLSYMS is not set
diff --git a/recipes-kernel/linux/linux-kexecboot-3.2/poodle/defconfig b/recipes-kernel/linux/linux-kexecboot-3.2/poodle/defconfig
index 141abd7..081282a 100644
--- a/recipes-kernel/linux/linux-kexecboot-3.2/poodle/defconfig
+++ b/recipes-kernel/linux/linux-kexecboot-3.2/poodle/defconfig
@@ -6,6 +6,7 @@ CONFIG_LOG_BUF_SHIFT=14
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE="initramfs.cpio.lzma"
CONFIG_RD_LZMA=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_INITRAMFS_COMPRESSION_LZMA=y
# CONFIG_UID16 is not set
# CONFIG_KALLSYMS is not set
diff --git a/recipes-kernel/linux/linux-kexecboot-3.2/spitz/defconfig b/recipes-kernel/linux/linux-kexecboot-3.2/spitz/defconfig
index 6c579fa..cf430c8 100644
--- a/recipes-kernel/linux/linux-kexecboot-3.2/spitz/defconfig
+++ b/recipes-kernel/linux/linux-kexecboot-3.2/spitz/defconfig
@@ -6,6 +6,7 @@ CONFIG_LOG_BUF_SHIFT=14
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE="initramfs.cpio.lzma"
CONFIG_RD_LZMA=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_INITRAMFS_COMPRESSION_LZMA=y
# CONFIG_UID16 is not set
# CONFIG_KALLSYMS is not set
diff --git a/recipes-kernel/linux/linux-kexecboot-3.2/tosa/defconfig b/recipes-kernel/linux/linux-kexecboot-3.2/tosa/defconfig
index 971c49a..40ea183 100644
--- a/recipes-kernel/linux/linux-kexecboot-3.2/tosa/defconfig
+++ b/recipes-kernel/linux/linux-kexecboot-3.2/tosa/defconfig
@@ -6,6 +6,7 @@ CONFIG_LOG_BUF_SHIFT=14
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE="initramfs.cpio.lzma"
CONFIG_RD_LZMA=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_INITRAMFS_COMPRESSION_LZMA=y
# CONFIG_UID16 is not set
# CONFIG_KALLSYMS is not set
diff --git a/recipes-kernel/linux/linux-kexecboot_3.2.bbappend b/recipes-kernel/linux/linux-kexecboot_3.2.bbappend
index 779deb9..b3f98b1 100644
--- a/recipes-kernel/linux/linux-kexecboot_3.2.bbappend
+++ b/recipes-kernel/linux/linux-kexecboot_3.2.bbappend
@@ -3,6 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux-kexecboot-${PV}:${THISDIR}/files:"
# wait until klibc_2.0 is out (march/april 2012)
DEFAULT_PREFERENCE = "-1"
+PR = "${INC_PR}.1"
COMPATIBLE_MACHINE = "(akita|c7x0|collie|poodle|tosa|spitz)"
# Note we set loglevel=3 and master console on serial to protect bootlogo.
diff --git a/recipes-kernel/linux/linux_3.2.bb b/recipes-kernel/linux/linux_3.2.bb
index 5379870..eb9cc34 100644
--- a/recipes-kernel/linux/linux_3.2.bb
+++ b/recipes-kernel/linux/linux_3.2.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "${INC_PR}.4"
+PR = "${INC_PR}.5"
COMPATIBLE_MACHINE = "(akita|c7x0|collie|poodle|tosa|spitz)"
SRC_URI += "${KERNELORG_MIRROR}/linux/kernel/v3.x/linux-${PV}.tar.bz2;name=kernel \