aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2015-04-18 23:11:50 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2015-05-07 00:10:22 +0100
commit736922d55ad4728a2efa7cc1cf44b803f3b3abdd (patch)
treefd6f759830fd0be37c88f277b42701bf952a2597 /recipes-kernel
parent4f8a45e1fe1923e78887d1608c92cd586679c790 (diff)
downloadmeta-handheld-736922d55ad4728a2efa7cc1cf44b803f3b3abdd.tar.gz
linux-gcw0(-kexecboot): upgrade from 3.19 to 4.0 dev release
following upstream progress Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-gcw0-4.0/gcw0/defconfig (renamed from recipes-kernel/linux/linux-gcw0-3.19/gcw0/defconfig)9
-rw-r--r--recipes-kernel/linux/linux-gcw0-kexecboot-4.0/gcw0/defconfig (renamed from recipes-kernel/linux/linux-gcw0-kexecboot-3.19/gcw0/defconfig)9
-rw-r--r--recipes-kernel/linux/linux-gcw0-kexecboot_4.0.bb (renamed from recipes-kernel/linux/linux-gcw0-kexecboot_3.19.bb)2
-rw-r--r--recipes-kernel/linux/linux-gcw0_4.0.bb (renamed from recipes-kernel/linux/linux-gcw0_3.19.bb)4
4 files changed, 14 insertions, 10 deletions
diff --git a/recipes-kernel/linux/linux-gcw0-3.19/gcw0/defconfig b/recipes-kernel/linux/linux-gcw0-4.0/gcw0/defconfig
index e605822..97a9fc6 100644
--- a/recipes-kernel/linux/linux-gcw0-3.19/gcw0/defconfig
+++ b/recipes-kernel/linux/linux-gcw0-4.0/gcw0/defconfig
@@ -1,17 +1,16 @@
-CONFIG_MACH_JZ4770=y
+CONFIG_MACH_INGENIC=y
+CONFIG_JZ4770_GCW0=y
CONFIG_HIGHMEM=y
# CONFIG_COMPACTION is not set
# CONFIG_BOUNCE is not set
CONFIG_PREEMPT_VOLUNTARY=y
CONFIG_KEXEC=y
# CONFIG_SECCOMP is not set
-CONFIG_LOCALVERSION="-dingux"
+CONFIG_LOCALVERSION="-yocto-standard"
# CONFIG_LOCALVERSION_AUTO is not set
-CONFIG_DEFAULT_HOSTNAME="gcw-zero"
# CONFIG_CROSS_MEMORY_ATTACH is not set
# CONFIG_USELIB is not set
CONFIG_NO_HZ_IDLE=y
-# CONFIG_INIT_FALLBACK is not set
# CONFIG_SGETMASK_SYSCALL is not set
# CONFIG_SYSFS_SYSCALL is not set
CONFIG_EMBEDDED=y
@@ -145,6 +144,8 @@ CONFIG_BACKLIGHT_PWM=y
CONFIG_PANEL_NT39016=y
CONFIG_GPU_VIVANTE_V4=y
# CONFIG_VGA_CONSOLE is not set
+CONFIG_DUMMY_CONSOLE_COLUMNS=53
+CONFIG_DUMMY_CONSOLE_ROWS=24
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_LOGO=y
# CONFIG_LOGO_LINUX_MONO is not set
diff --git a/recipes-kernel/linux/linux-gcw0-kexecboot-3.19/gcw0/defconfig b/recipes-kernel/linux/linux-gcw0-kexecboot-4.0/gcw0/defconfig
index 259bcc9..2e976b4 100644
--- a/recipes-kernel/linux/linux-gcw0-kexecboot-3.19/gcw0/defconfig
+++ b/recipes-kernel/linux/linux-gcw0-kexecboot-4.0/gcw0/defconfig
@@ -1,12 +1,13 @@
-CONFIG_MACH_JZ4770=y
+CONFIG_MACH_INGENIC=y
+CONFIG_JZ4770_GCW0=y
CONFIG_HIGHMEM=y
# CONFIG_COMPACTION is not set
# CONFIG_BOUNCE is not set
CONFIG_PREEMPT_VOLUNTARY=y
CONFIG_KEXEC=y
# CONFIG_SECCOMP is not set
+CONFIG_LOCALVERSION="-yocto-standard"
# CONFIG_LOCALVERSION_AUTO is not set
-CONFIG_DEFAULT_HOSTNAME="gcw-zero"
# CONFIG_CROSS_MEMORY_ATTACH is not set
# CONFIG_USELIB is not set
CONFIG_NO_HZ_IDLE=y
@@ -17,7 +18,6 @@ CONFIG_INITRAMFS_SOURCE="initramfs.cpio.gz"
# CONFIG_RD_XZ is not set
# CONFIG_RD_LZO is not set
# CONFIG_RD_LZ4 is not set
-# CONFIG_INIT_FALLBACK is not set
# CONFIG_SGETMASK_SYSCALL is not set
# CONFIG_SYSFS_SYSCALL is not set
CONFIG_EMBEDDED=y
@@ -151,6 +151,8 @@ CONFIG_BACKLIGHT_PWM=y
CONFIG_PANEL_NT39016=y
CONFIG_GPU_VIVANTE_V4=y
# CONFIG_VGA_CONSOLE is not set
+CONFIG_DUMMY_CONSOLE_COLUMNS=53
+CONFIG_DUMMY_CONSOLE_ROWS=24
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_LOGO=y
# CONFIG_LOGO_LINUX_MONO is not set
@@ -195,6 +197,7 @@ CONFIG_PWM=y
CONFIG_PWM_JZ4740=y
CONFIG_EXT2_FS=y
CONFIG_EXT2_FS_XATTR=y
+CONFIG_EXT3_FS=y
CONFIG_EXT4_FS=y
# CONFIG_DNOTIFY is not set
CONFIG_MSDOS_FS=y
diff --git a/recipes-kernel/linux/linux-gcw0-kexecboot_3.19.bb b/recipes-kernel/linux/linux-gcw0-kexecboot_4.0.bb
index 43baae5..0041588 100644
--- a/recipes-kernel/linux/linux-gcw0-kexecboot_3.19.bb
+++ b/recipes-kernel/linux/linux-gcw0-kexecboot_4.0.bb
@@ -1,4 +1,4 @@
-require recipes-kernel/linux/linux-gcw0_3.19.bb
+require recipes-kernel/linux/linux-gcw0_4.0.bb
SUMMARY = "GCW Zero kernel embedding a minimalistic kexecboot initramfs"
PACKAGES = ""
diff --git a/recipes-kernel/linux/linux-gcw0_3.19.bb b/recipes-kernel/linux/linux-gcw0_4.0.bb
index 80ab3bf..85f315c 100644
--- a/recipes-kernel/linux/linux-gcw0_3.19.bb
+++ b/recipes-kernel/linux/linux-gcw0_4.0.bb
@@ -5,10 +5,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
COMPATIBLE_MACHINE = "gcw0"
-SRC_URI = "git://github.com/gcwnow/linux.git;branch=jz-3.19 \
+SRC_URI = "git://github.com/gcwnow/linux.git;branch=jz-4.0 \
file://defconfig \
"
-SRCREV = "9482cbbce300c7ae7ff3faa99abc7d5cb319d915"
+SRCREV = "5480c81f8c145a06a5ec1f405e5639c579d7c4ac"
inherit kernel