aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/formfactor/formfactor_0.0.bbappend15
1 files changed, 14 insertions, 1 deletions
diff --git a/recipes-bsp/formfactor/formfactor_0.0.bbappend b/recipes-bsp/formfactor/formfactor_0.0.bbappend
index e406684..e888ec1 100644
--- a/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ b/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -1,4 +1,17 @@
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+do_install_prepend () {
+ # provide machine-specific /etc/rotation for psplash
+ sed -n 's/^[ \t]DISPLAY_ORIENTATION[ \t]*//p' ${S}/machconfig | tr -dc '[0-9]' > ${S}/rotation
+ printf "\n" >> ${S}/rotation
+}
+
+do_install_append () {
+ # Only install file if it has a content
+ if [ -s "${S}/rotation" ]; then
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${S}/rotation ${D}${sysconfdir}/rotation
+ fi
+}