aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-handheld-4.4/dmaengine-mmp-pdma-add-number-of-requestors.patch34
-rw-r--r--recipes-kernel/linux/linux-handheld_4.4.bb11
2 files changed, 41 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-handheld-4.4/dmaengine-mmp-pdma-add-number-of-requestors.patch b/recipes-kernel/linux/linux-handheld-4.4/dmaengine-mmp-pdma-add-number-of-requestors.patch
new file mode 100644
index 0000000..02287a4
--- /dev/null
+++ b/recipes-kernel/linux/linux-handheld-4.4/dmaengine-mmp-pdma-add-number-of-requestors.patch
@@ -0,0 +1,34 @@
+From 4ab014655ebad342c6e7beae427c5cc0f8141d2b Mon Sep 17 00:00:00 2001
+From: Robert Jarzmik <robert.jarzmik@free.fr>
+Date: Mon, 15 Feb 2016 21:57:46 +0100
+Subject: dmaengine: mmp-pdma: add number of requestors
+
+commit c283e41ef32442f41e7180f9bb1c5aedf9255bfe upstream.
+
+The DMA chip has a fixed number of requestor lines used for flow
+control. This number is platform dependent. The pxa_dma dma driver will
+use this value to activate or not the flow control.
+
+There won't be any impact on mmp_pdma driver.
+
+Signed-off-by: Robert Jarzmik <robert.jarzmik@free.fr>
+Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
+---
+ include/linux/platform_data/mmp_dma.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/linux/platform_data/mmp_dma.h b/include/linux/platform_data/mmp_dma.h
+index 2a330ec..d1397c8 100644
+--- a/include/linux/platform_data/mmp_dma.h
++++ b/include/linux/platform_data/mmp_dma.h
+@@ -14,6 +14,7 @@
+
+ struct mmp_dma_platdata {
+ int dma_channels;
++ int nb_requestors;
+ };
+
+ #endif /* MMP_DMA_H */
+--
+cgit v0.12
+
diff --git a/recipes-kernel/linux/linux-handheld_4.4.bb b/recipes-kernel/linux/linux-handheld_4.4.bb
index 7b64896..4532523 100644
--- a/recipes-kernel/linux/linux-handheld_4.4.bb
+++ b/recipes-kernel/linux/linux-handheld_4.4.bb
@@ -6,14 +6,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
COMPATIBLE_MACHINE = "akita|c7x0|collie|h3600|hx4700|poodle|spitz|tosa"
SRC_URI = "${KERNELORG_MIRROR}/linux/kernel/v4.x/linux-${PV}.tar.xz;name=kernel \
- ${KERNELORG_MIRROR}/linux/kernel/v4.x/patch-${PV}.8.xz;apply=yes;name=stablepatch \
+ ${KERNELORG_MIRROR}/linux/kernel/v4.x/patch-${PV}.10.xz;apply=yes;name=stablepatch \
"
SRC_URI[kernel.md5sum] = "9a78fa2eb6c68ca5a40ed5af08142599"
SRC_URI[kernel.sha256sum] = "401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2"
-SRC_URI[stablepatch.md5sum] = "c1d8f46e5b2ee7c925fc38f20a3726d3"
-SRC_URI[stablepatch.sha256sum] = "11ec99ae0600bd831ff8d71b77e64592f4b6918b7857fd9ff0284ea4cf267b4e"
+SRC_URI[stablepatch.md5sum] = "1b9a296c0d0b778e8173299618f2d84f"
+SRC_URI[stablepatch.sha256sum] = "df66bd2532cac85dfb85d6ca9b750689e02278442652a0b047304e3322947d17"
-SRC_URI += "file://ASoC-pxa-fix-module-autoload-for-platform-drivers.patch"
+SRC_URI += "\
+ file://ASoC-pxa-fix-module-autoload-for-platform-drivers.patch \
+ file://dmaengine-mmp-pdma-add-number-of-requestors.patch \
+ "
LOCOMO_PATCHES = "\
file://locomo/0001-mfd-add-new-driver-for-Sharp-LoCoMo.patch \