aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/kexecboot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/kexecboot')
-rw-r--r--recipes-bsp/kexecboot/kexecboot-klibc_git.bb4
-rw-r--r--recipes-bsp/kexecboot/kexecboot.inc3
-rw-r--r--recipes-bsp/kexecboot/kexecboot_git.bb4
3 files changed, 6 insertions, 5 deletions
diff --git a/recipes-bsp/kexecboot/kexecboot-klibc_git.bb b/recipes-bsp/kexecboot/kexecboot-klibc_git.bb
index 22ef7de..0d6d00f 100644
--- a/recipes-bsp/kexecboot/kexecboot-klibc_git.bb
+++ b/recipes-bsp/kexecboot/kexecboot-klibc_git.bb
@@ -1,9 +1,9 @@
RDEPENDS_${PN} = "kexec-klibc"
PV = "0.5.9"
-PR = "r7+gitr${SRCREV}"
+PR = "r8+gitr${SRCREV}"
SRC_URI = "git://git.linuxtogo.org/home/groups/kexecboot/kexecboot.git;protocol=git "
-SRCREV = "14e6d1a3641a749e4408fda1eadffe4f396b0279"
+SRCREV = "8f1d3cc3d9c650c6a6c88f83071185d6ee0ef9c7"
S = "${WORKDIR}/git"
# the binary is statically linked against klibc
diff --git a/recipes-bsp/kexecboot/kexecboot.inc b/recipes-bsp/kexecboot/kexecboot.inc
index b76abcc..3a7fd9f 100644
--- a/recipes-bsp/kexecboot/kexecboot.inc
+++ b/recipes-bsp/kexecboot/kexecboot.inc
@@ -50,11 +50,12 @@ do_install () {
install -m 0755 kexecboot ${D}${bindir}/
install -d ${D}/proc
install -d ${D}/mnt
+ install -d ${D}/dev
}
PACKAGE_ARCH = "${MACHINE_ARCH}"
-FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt"
+FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev"
pkg_postinst_${PN} () {
ln -sf ${bindir}/kexecboot $D/init
diff --git a/recipes-bsp/kexecboot/kexecboot_git.bb b/recipes-bsp/kexecboot/kexecboot_git.bb
index 264d8e2..1341461 100644
--- a/recipes-bsp/kexecboot/kexecboot_git.bb
+++ b/recipes-bsp/kexecboot/kexecboot_git.bb
@@ -1,9 +1,9 @@
RDEPENDS_${PN} = "kexec"
PV = "0.5.9"
-PR = "r7+gitr${SRCREV}"
+PR = "r8+gitr${SRCREV}"
SRC_URI = "git://git.linuxtogo.org/home/groups/kexecboot/kexecboot.git;protocol=git "
-SRCREV = "14e6d1a3641a749e4408fda1eadffe4f396b0279"
+SRCREV = "8f1d3cc3d9c650c6a6c88f83071185d6ee0ef9c7"
S = "${WORKDIR}/git"
require kexecboot.inc