aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ezx/ezx-gen-blob_git.bb41
-rw-r--r--recipes-bsp/ezx/ezx-gpiotool_svn.bb24
-rw-r--r--recipes-bsp/ezx/ezxd/ezxd.init83
-rw-r--r--recipes-bsp/ezx/ezxd_svn.bb48
-rw-r--r--recipes-bsp/ezx/files/remove-bogus-sed.patch15
-rw-r--r--recipes-bsp/ezx/moto-boot-usb-native_git.bb27
6 files changed, 0 insertions, 238 deletions
diff --git a/recipes-bsp/ezx/ezx-gen-blob_git.bb b/recipes-bsp/ezx/ezx-gen-blob_git.bb
deleted file mode 100644
index 1b7647d..0000000
--- a/recipes-bsp/ezx/ezx-gen-blob_git.bb
+++ /dev/null
@@ -1,41 +0,0 @@
-DESCRIPTION = "Generic Blob [Bootloader] for the Motorola EZX platform"
-SECTION = "bootloaders"
-AUTHOR = "OpenEZX Team"
-HOMEPAGE = "http://people.openezx.org/wyrm/gen-blob"
-LICENSE = "GPL"
-PROVIDES = "virtual/bootloader"
-DEPENDS = "virtual/kernel"
-SRCREV = "33d6abb6ae51cda8c8298ba63033cd11ea4b045c"
-PV = "1.0.0+gitr${SRCPV}"
-PR = "r0"
-PE = "1"
-
-SRC_URI = "\
- git://git.openezx.org/gen-blob.git;protocol=git;branch=master \
- file://remove-bogus-sed.patch \
-"
-S = "${WORKDIR}/git"
-
-inherit autotools
-
-EXTRA_OECONF = "\
- --with-board=lubbock \
- --with-cpu=pxa262 \
- --with-linux-prefix=${STAGING_KERNEL_DIR} \
- --enable-usb \
-"
-
-do_configure() {
- gnu-configize
- oe_runconf
-}
-
-do_deploy() {
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 0644 src/blob/blob-a780 ${DEPLOY_DIR_IMAGE}/gen-blob-for-1stgen.${SRCDATE}
- install -m 0644 src/blob/blob-a1200 ${DEPLOY_DIR_IMAGE}/gen-blob-for-2ndgen.${SRCDATE}
-}
-
-addtask deploy before do_build after do_compile
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/ezx/ezx-gpiotool_svn.bb b/recipes-bsp/ezx/ezx-gpiotool_svn.bb
deleted file mode 100644
index ed733a2..0000000
--- a/recipes-bsp/ezx/ezx-gpiotool_svn.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Gpiotool can read/write gpio configuration from userspace."
-SECTION = "devel"
-LICENSE = "GPL"
-HOMEPAGE = "http://www.openezx.org"
-AUTHOR = "Harald Welte"
-SRCREV = "1877"
-PV = "${SRCPV}"
-PR = "r1"
-
-SRC_URI = "svn://svn.openezx.org/trunk/src/userspace;module=gpiotool;protocol=http"
-S = "${WORKDIR}/gpiotool"
-
-do_compile() {
- for i in mmio.c gpiotool.c gpio.c
- do
- ${CC} ${CFLAGS} -c $i
- done
- ${CC} ${CFLAGS} ${LDFLAGS} -o ezx-gpiotool mmio.o gpiotool.o gpio.o
-}
-
-do_install() {
- install -d ${D}${sbindir}
- install -m 0755 ezx-gpiotool ${D}${sbindir}
-}
diff --git a/recipes-bsp/ezx/ezxd/ezxd.init b/recipes-bsp/ezx/ezxd/ezxd.init
deleted file mode 100644
index ba44942..0000000
--- a/recipes-bsp/ezx/ezxd/ezxd.init
+++ /dev/null
@@ -1,83 +0,0 @@
-#! /bin/sh
-# -*- coding: utf-8 -*-
-# init.d script for ezxd
-
-set -e
-
-DAEMON=/usr/bin/ezxd
-NAME=ezxd
-PIDDIR=/var/run/ezxd
-PIDFILE=$PIDDIR/pid
-DESC="ezxd server"
-
-test -x $DAEMON || exit 0
-
-# Source defaults file; edit that file to configure this script.
-ENABLED=1
-PARAMS=""
-if [ -e /etc/default/ezxd ]; then
- . /etc/default/ezxd
-fi
-
-test "$ENABLED" != "0" || exit 0
-
-start_it_up()
-{
- if [ ! -d $PIDDIR ]; then
- mkdir -p $PIDDIR
- fi
- if [ -e $PIDFILE ]; then
- PIDDIR=/proc/$(cat $PIDFILE)
- if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
- echo "$DESC already started; not starting."
- else
- echo "Removing stale PID file $PIDFILE."
- rm -f $PIDFILE
- fi
- fi
-
- echo -n "Starting $DESC: "
- modprobe ohci-hcd
- sleep 2
- modprobe moto-usb-ipc
- modprobe ts27010mux
-
- start-stop-daemon --start --background --quiet --pidfile $PIDFILE \
- --exec $DAEMON -- --system $PARAMS
- # We need to sleep here because opening the mux devices takes some time
- sleep 15
- echo "$NAME."
-}
-
-shut_it_down()
-{
- echo -n "Stopping $DESC: "
- start-stop-daemon --stop --quiet --pidfile $PIDFILE
-
- # We no longer include these arguments so that start-stop-daemon
- # can do its job even given that we may have been upgraded.
- # We rely on the pidfile being sanely managed
- # --exec $DAEMON -- --system $PARAMS
- echo "$NAME."
- rm -f $PIDFILE
-}
-
-case "$1" in
- start)
- start_it_up
- ;;
- stop)
- shut_it_down
- ;;
- restart|force-reload)
- shut_it_down
- sleep 1
- start_it_up
- ;;
- *)
- echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/recipes-bsp/ezx/ezxd_svn.bb b/recipes-bsp/ezx/ezxd_svn.bb
deleted file mode 100644
index 7b69454..0000000
--- a/recipes-bsp/ezx/ezxd_svn.bb
+++ /dev/null
@@ -1,48 +0,0 @@
-DESCRIPTION = "Open implementation of motorola's tapisrv, replaces opentapi"
-LICENSE = "GPLv2+"
-SECTION = "devel"
-AUTHOR = "Daniel Ribeiro"
-
-SRCREV = "2513"
-PV = "0.0+svnr${SRCPV}"
-PR = "r4"
-LIC_FILES_CHKSUM = "file://plugin.c;endline=19;md5=16da36fbb577507b411368f133ce2067"
-SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=ezxd;protocol=http \
- file://ezxd.init \
- "
-
-inherit update-rc.d
-
-INITSCRIPT_NAME = "ezxd"
-INITSCRIPT_PARAMS = "start 00 S ."
-
-S = "${WORKDIR}/${PN}"
-
-CFLAGS_append = " -DDEBUG -fPIC "
-
-TARGET_CC_ARCH += "${LDFLAGS} -fPIC"
-
-do_configure() {
- # Comment out both CC and CROSS definitions
- sed -i -e 's:^CC.*$:#\0:g' Makefile
- sed -i -e 's:^CROSS.*$:#\0:g' Makefile
-}
-
-fakeroot do_install() {
- install -d ${D}/dev/input
- mknod ${D}/dev/input/uinput c 10 223
-
- install -d ${D}${bindir}
- install -m 755 ezxd ${D}${bindir}
-
- install -d ${D}${libdir}/ezxd
- install -m 755 *.so ${D}${libdir}/ezxd
-
- install -d ${D}${sysconfdir}/init.d
- install -m 0600 ezxd.conf ${D}${sysconfdir}/
- install -m 0755 ${WORKDIR}/ezxd.init ${D}${sysconfdir}/init.d/ezxd
-}
-
-FILES_${PN} += "/dev"
-CONFFILES_${PN} += "${sysconfdir}/ezxd.conf"
-
diff --git a/recipes-bsp/ezx/files/remove-bogus-sed.patch b/recipes-bsp/ezx/files/remove-bogus-sed.patch
deleted file mode 100644
index 8597ed9..0000000
--- a/recipes-bsp/ezx/files/remove-bogus-sed.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: gen-blob/configure
-===================================================================
---- gen-blob.orig/configure
-+++ gen-blob/configure
-@@ -1970,8 +1970,8 @@
- fi
-
-
--CFLAGS=`echo $CFLAGS | sed 's/\ *-g\ */\ /'`
--LDFLAGS=`echo $LDFLAGS | sed 's/\ *-g\ */\ /'`
-+CFLAGS=`echo $CFLAGS`
-+LDFLAGS=`echo $LDFLAGS`
- CCAS=`echo $CC`
- CCASFLAGS=`echo $CFLAGS -D__ASSEMBLY__ `
-
diff --git a/recipes-bsp/ezx/moto-boot-usb-native_git.bb b/recipes-bsp/ezx/moto-boot-usb-native_git.bb
deleted file mode 100644
index 5147d72..0000000
--- a/recipes-bsp/ezx/moto-boot-usb-native_git.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-DESCRIPTION = "Boot a Motorola EZX device with a user supplied kernel"
-DEPENDS = "virtual/libusb0-native virtual/kernel"
-SECTION = "devel"
-AUTHOR = "Team OpenEZX <openezx-devel@lists.openezx.org>"
-LICENSE = "GPL"
-SRCREV = "aeef3f44a1358fee15da193876e8ebc716dcd550"
-PV = "0.3.0+gitr${SRCPV}"
-PR = "r0"
-PE = "1"
-
-SRC_URI = "git://git.openezx.org/moto-boot-usb.git;protocol=git;branch=master"
-S = "${WORKDIR}/git"
-
-EXTRA_OECONF := '--with-kernel-dir="${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"'
-
-inherit autotools native
-
-do_deploy() {
- install -d ${DEPLOY_DIR_TOOLS}
- install -m 0755 src/moto-boot-usb ${DEPLOY_DIR_TOOLS}/moto-boot-usb-${PV}
-}
-
-do_install() {
- :
-}
-
-addtask deploy before do_build after do_compile