summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorPhil Blundell <philb@brightsign.biz>2011-05-16 12:06:43 +0100
committerPhil Blundell <philb@brightsign.biz>2011-05-16 12:06:43 +0100
commit17009a37b2571be21a91aaf4aef7a6fedcfeba9c (patch)
tree6d993bf7378fc70a555cfe43efb2ddb05212a4f1 /recipes
parent14cf3e8a0f3391902a7b3b039145c72253cc8010 (diff)
downloadmeta-micro-17009a37b2571be21a91aaf4aef7a6fedcfeba9c.tar.gz
busybox: make sure /proc and /sys are mounted before starting mdev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/busybox/busybox_1.18.4.bbappend2
-rw-r--r--recipes/busybox/files/mdev9
-rw-r--r--recipes/images/micro-base-image.bb1
3 files changed, 12 insertions, 0 deletions
diff --git a/recipes/busybox/busybox_1.18.4.bbappend b/recipes/busybox/busybox_1.18.4.bbappend
index febfad6..435ba43 100644
--- a/recipes/busybox/busybox_1.18.4.bbappend
+++ b/recipes/busybox/busybox_1.18.4.bbappend
@@ -1,2 +1,4 @@
+PR .= ".2"
+
THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}-${PV}"], d)}:"
diff --git a/recipes/busybox/files/mdev b/recipes/busybox/files/mdev
new file mode 100644
index 0000000..14ba837
--- /dev/null
+++ b/recipes/busybox/files/mdev
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+mount proc /proc -t proc
+mount sys /sys -t sysfs
+mount -t tmpfs tmpfs /dev -o size=64k,mode=0755
+mkdir /dev/pts /dev/shm
+mount -t devpts devpts /dev/pts
+echo "/sbin/mdev" > /proc/sys/kernel/hotplug
+mdev -s
diff --git a/recipes/images/micro-base-image.bb b/recipes/images/micro-base-image.bb
index 95993d6..3080657 100644
--- a/recipes/images/micro-base-image.bb
+++ b/recipes/images/micro-base-image.bb
@@ -8,6 +8,7 @@ IMAGE_INSTALL = "base-files \
base-passwd \
dropbear \
netbase \
+ busybox \
busybox-mdev \
sysvinit sysvinit-pidof"
IMAGE_LINGUAS = ""