aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Fekih, Hichem <hichem.benfekih@ifm.com>2022-04-21 13:41:11 +0200
committerKhem Raj <raj.khem@gmail.com>2022-04-22 11:08:25 -0700
commitec6d073518604be7327ea971b681bacd728d8888 (patch)
tree0bc6a6f8f9154aff0e908432d9a0b7f157b3b4ee
parentb932a20f26ea444b256fb0adf72e0d0982ade20b (diff)
downloadmeta-openembedded-contrib-ec6d073518604be7327ea971b681bacd728d8888.tar.gz
sdbus-c++-libsystemd: bugfix dev package is not installed
since sdbus-c++-libsystemd outputs only static libraries, it will not be installed inside the SDK. add RDEPENDS:${PN}-dev = "" to remove the dependency to the empty package when installing the sdbus-c++-libsystemd-dev into the SDK without this change the SDK is missing sdbus-c++-dev and sdbus-c++-libsystemd-dev Signed-off-by: Ben Fekih, Hichem <hichem.benfekih@ifm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd_250.3.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd_250.3.bb b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd_250.3.bb
index 6d72eb64b3..6bb5f7abb8 100644
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd_250.3.bb
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd_250.3.bb
@@ -59,6 +59,8 @@ EXTRA_OEMESON += "-Dstatic-libsystemd=pic"
S = "${WORKDIR}/git"
+RDEPENDS:${PN}-dev = ""
+
do_compile() {
ninja -v ${PARALLEL_MAKE} version.h
ninja -v ${PARALLEL_MAKE} libsystemd.a