aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2016-06-02 23:10:06 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:28 +0200
commit4c110ff936390c9c4a908eb9cc0de8beec241eb3 (patch)
tree8ffdb1fcd8c3d5109ece9112cc8c2b8688392c35
parent4594d24bc082d326993e7fd545ca4ac722749953 (diff)
downloadmeta-openembedded-contrib-4c110ff936390c9c4a908eb9cc0de8beec241eb3.tar.gz
python-backports-abc: initial recipe for version 0.4
This package backports Python 3.4 collections.abc to earlier Python versions. It is being added as one of the two missing backport modules that Tornado 4.3 needs in order to prevent tornado/gen.py from bombing on import errors when running on python2 rather than python3.4 ImportError: No module named backports_abc Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-backports-abc_0.4.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-backports-abc_0.4.bb b/meta-python/recipes-devtools/python/python-backports-abc_0.4.bb
new file mode 100644
index 0000000000..6a4d267bc7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-backports-abc_0.4.bb
@@ -0,0 +1,18 @@
+SUMMARY = "collections.abc from Python 3.4"
+DESCRIPTION = "A backport of recent additions to the 'collections.abc' module"
+
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=dd98d01d471fac8d8dbdd975229dba03"
+
+# pypi package doesn't have valid entry for license
+SRC_URI += "https://raw.githubusercontent.com/cython/backports_abc/master/LICENSE;name=license"
+
+SRC_URI[md5sum] = "0b65a216ce9dc9c1a7e20a729dd7c05b"
+SRC_URI[sha256sum] = "8b3e4092ba3d541c7a2f9b7d0d9c0275b21c6a01c53a61c731eba6686939d0a5"
+SRC_URI[license.md5sum] = "dd98d01d471fac8d8dbdd975229dba03"
+SRC_URI[license.sha256sum] = "0a4f3b38055f50f047a42521568fa6ddb9a5976c2884f6ae138796d0f71150ca"
+
+
+
+PYPI_PACKAGE = "backports_abc"
+inherit pypi setuptools