aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-11-02 21:42:38 -0700
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:34:06 -0800
commit93e56000ccf371f7e4285eec1717ff4bf08e9c49 (patch)
tree0ad657144bd19f58a26d1c06382413fcab92551e
parenta72fc487dad1b8a239efa96b7ea8b156716bd061 (diff)
downloadmeta-openembedded-contrib-93e56000ccf371f7e4285eec1717ff4bf08e9c49.tar.gz
whetstone_1.2.bb: Add whetstone benchmark
The Whetstone benchmark is a synthetic benchmark for evaluating the performance of computers. https://en.wikipedia.org/wiki/Whetstone_(benchmark) Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com> Acked-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-benchmark/whetstone/whetstone_1.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/whetstone/whetstone_1.2.bb b/meta-oe/recipes-benchmark/whetstone/whetstone_1.2.bb
new file mode 100644
index 0000000000..8fad04e365
--- /dev/null
+++ b/meta-oe/recipes-benchmark/whetstone/whetstone_1.2.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Whetstone benchmark is a synthetic benchmark for evaluating the performance of computers"
+SUMMARY = "CPU benchmark to measure floating point performance"
+
+LICENSE = "PD"
+LIC_FILES_CHKSUM ="file://${WORKDIR}/whetstone.c;beginline=1;endline=52;md5=c795edc15e7e1d92ca8f88ad718449f5"
+
+SRC_URI = "http://www.netlib.org/benchmark/whetstone.c"
+SRC_URI[md5sum] = "d8eb2cd7104bb5a12d614ac6d3f1f9fb"
+SRC_URI[sha256sum] = "333e4ceca042c146f63eec605573d16ae8b07166cbc44a17bec1ea97c6f1efbf"
+
+S = "${WORKDIR}"
+
+do_compile () {
+ ${CC} ${CFLAGS} ${LDFLAGS} -Ofast -o whetstone whetstone.c -lm
+}
+
+do_install () {
+ install -Dm 0755 whetstone ${D}${bindir}/whetstone
+}
+