aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-21 11:20:34 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-22 20:09:57 -0800
commit6f45a7ed4c36893de9db48ed79deb4e61e2734e7 (patch)
tree4378ca04c00b9443ef9e9b6a2a3f5b064eec4ac4
parent7ba61902e6ee39d5fbb4e8e10288e76a1c4468bc (diff)
downloadmeta-openembedded-contrib-6f45a7ed4c36893de9db48ed79deb4e61e2734e7.tar.gz
Remove deprecated python3-lang from the RDEPENDS
The python3-lang package was removed as part of the migration to the json manifest file. The functionality is now part of core Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-jinja2.inc2
-rw-r--r--meta-python/recipes-devtools/python/python-jinja2_2.10.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-pyasn1.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-pyasn1_0.4.2.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography_2.1.4.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb6
-rw-r--r--meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb2
9 files changed, 7 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-jinja2.inc b/meta-python/recipes-devtools/python/python-jinja2.inc
index 72562fb53b..510765b286 100644
--- a/meta-python/recipes-devtools/python/python-jinja2.inc
+++ b/meta-python/recipes-devtools/python/python-jinja2.inc
@@ -9,7 +9,7 @@ SRC_URI[sha256sum] = "f84be1bb0040caca4cea721fcbbbbd61f9be9464ca236387158b0feea0
RDEPENDS_${PN} += "${PYTHON_PN}-io ${PYTHON_PN}-pickle ${PYTHON_PN}-crypt \
${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-textutils \
- ${PYTHON_PN}-lang ${PYTHON_PN}-pprint ${PYTHON_PN}-shell ${PYTHON_PN}-markupsafe \
+ ${PYTHON_PN}-pprint ${PYTHON_PN}-shell ${PYTHON_PN}-markupsafe \
${PYTHON_PN}-json ${PYTHON_PN}-threading ${PYTHON_PN}-numbers"
CLEANBROKEN = "1"
diff --git a/meta-python/recipes-devtools/python/python-jinja2_2.10.bb b/meta-python/recipes-devtools/python/python-jinja2_2.10.bb
index 19b2bfaf68..06075213f7 100644
--- a/meta-python/recipes-devtools/python/python-jinja2_2.10.bb
+++ b/meta-python/recipes-devtools/python/python-jinja2_2.10.bb
@@ -1,4 +1,4 @@
inherit pypi setuptools
require python-jinja2.inc
-RDEPENDS_${PN} += "${PYTHON_PN}-re"
+RDEPENDS_${PN} += "${PYTHON_PN}-lang ${PYTHON_PN}-re"
diff --git a/meta-python/recipes-devtools/python/python-jsonschema.inc b/meta-python/recipes-devtools/python/python-jsonschema.inc
index b602b27b96..748ef6e2ee 100644
--- a/meta-python/recipes-devtools/python/python-jsonschema.inc
+++ b/meta-python/recipes-devtools/python/python-jsonschema.inc
@@ -11,7 +11,6 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-core \
${PYTHON_PN}-io \
${PYTHON_PN}-json \
- ${PYTHON_PN}-lang \
${PYTHON_PN}-netclient \
${PYTHON_PN}-numbers \
${PYTHON_PN}-pkgutil \
diff --git a/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb b/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb
index 55cbb20206..c118f2d8a0 100644
--- a/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb
+++ b/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb
@@ -5,5 +5,6 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-argparse \
${PYTHON_PN}-contextlib \
${PYTHON_PN}-functools32 \
+ ${PYTHON_PN}-lang \
${PYTHON_PN}-re \
"
diff --git a/meta-python/recipes-devtools/python/python-pyasn1.inc b/meta-python/recipes-devtools/python/python-pyasn1.inc
index 2539101ce3..f3c32e08af 100644
--- a/meta-python/recipes-devtools/python/python-pyasn1.inc
+++ b/meta-python/recipes-devtools/python/python-pyasn1.inc
@@ -8,7 +8,6 @@ SRC_URI[sha256sum] = "d258b0a71994f7770599835249cece1caef3c70def868c4915e6e5ca49
RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-codecs \
- ${PYTHON_PN}-lang \
${PYTHON_PN}-logging \
${PYTHON_PN}-math \
${PYTHON_PN}-shell \
diff --git a/meta-python/recipes-devtools/python/python-pyasn1_0.4.2.bb b/meta-python/recipes-devtools/python/python-pyasn1_0.4.2.bb
index 4461918cac..a13c74dda8 100644
--- a/meta-python/recipes-devtools/python/python-pyasn1_0.4.2.bb
+++ b/meta-python/recipes-devtools/python/python-pyasn1_0.4.2.bb
@@ -1,2 +1,6 @@
inherit pypi setuptools
require python-pyasn1.inc
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-lang \
+"
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_2.1.4.bb b/meta-python/recipes-devtools/python/python3-cryptography_2.1.4.bb
index f807042ec0..f64e51d3f1 100644
--- a/meta-python/recipes-devtools/python/python3-cryptography_2.1.4.bb
+++ b/meta-python/recipes-devtools/python/python3-cryptography_2.1.4.bb
@@ -4,7 +4,3 @@ require python-cryptography.inc
SRC_URI += " \
file://run-ptest \
"
-
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-lang \
-"
diff --git a/meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb b/meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb
index 0292555c74..a62d944bac 100644
--- a/meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb
@@ -1,8 +1,2 @@
require python-pyudev.inc
-
-RDEPENDS_${PN} = "\
- ${PYTHON_PN}-lang \
-"
-
inherit pypi setuptools3
-
diff --git a/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb b/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
index d7533d8e70..dfb9d4a4cc 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
@@ -1,8 +1,6 @@
inherit pypi setuptools3
require python-twisted.inc
-RDEPENDS_${PN}-core += "python3-lang"
-
FILES_${PN}-core_append += " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \
${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__pycache__/*pyc \