aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-06-09 11:13:32 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-15 12:13:15 +0200
commit03f0be623831a3a7e039643c637f7a4b84d1d467 (patch)
tree5f3e6db07819a7d639cb8f0444683b887345af0b
parent7d399caee6adc82812f631f756b7805d866bad83 (diff)
downloadmeta-openembedded-contrib-03f0be623831a3a7e039643c637f7a4b84d1d467.tar.gz
mpv: use waf.bbclass
Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-multimedia/mplayer/mpv_0.15.0.bb23
1 files changed, 6 insertions, 17 deletions
diff --git a/meta-oe/recipes-multimedia/mplayer/mpv_0.15.0.bb b/meta-oe/recipes-multimedia/mplayer/mpv_0.15.0.bb
index 5fac298fa6..768c87ae2e 100644
--- a/meta-oe/recipes-multimedia/mplayer/mpv_0.15.0.bb
+++ b/meta-oe/recipes-multimedia/mplayer/mpv_0.15.0.bb
@@ -12,14 +12,14 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=91f1cb870c1cc2d31351a4d2595441cb"
SRC_URI = "https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz;name=mpv \
- http://www.freehackers.org/~tnagy/release/waf-1.8.12;name=waf \
+ http://www.freehackers.org/~tnagy/release/waf-1.8.12;name=waf;subdir=${BPN}-${PV} \
"
SRC_URI[mpv.md5sum] = "9042bd3fbff2bc8ba0b7fadaa4a22101"
SRC_URI[mpv.sha256sum] = "7d31217ba8572f364fcea2955733f821374ae6d8c6d8f22f8bc63c44c0400bdc"
SRC_URI[waf.md5sum] = "cef4ee82206b1843db082d0b0506bf71"
SRC_URI[waf.sha256sum] = "01bf2beab2106d1558800c8709bc2c8e496d3da4a2ca343fe091f22fca60c98b"
-inherit pkgconfig pythonnative distro_features_check
+inherit waf pkgconfig pythonnative distro_features_check
# Note: both lua and libass are required to get on-screen-display (controls)
PACKAGECONFIG ??= "lua libass"
@@ -28,6 +28,7 @@ PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass"
PACKAGECONFIG[libarchive] = "--enable-libarchive,--disable-libarchive,libarchive"
PACKAGECONFIG[jack] = "--enable-jack, --disable-jack, jack"
+SIMPLE_TARGET_SYS = "${@'${TARGET_SYS}'.replace('${TARGET_VENDOR}', '')}"
EXTRA_OECONF = " \
--prefix=${prefix} \
--target=${SIMPLE_TARGET_SYS} \
@@ -50,21 +51,9 @@ EXTRA_OECONF = " \
--disable-vapoursynth-lazy \
"
-do_configure() {
- if [ ! -L ../waf ]; then
- chmod a+x ../waf-1.8.12
- ln -s waf-1.8.12 ../waf
- fi
- export SIMPLE_TARGET_SYS="$(echo ${TARGET_SYS} | sed s:${TARGET_VENDOR}::g)"
- ../waf configure ${EXTRA_OECONF}
-}
-
-do_compile () {
- ../waf build
-}
-
-do_install() {
- ../waf install --destdir=${D}
+do_configure_prepend () {
+ ln -sf waf-1.8.12 ${S}/waf
+ chmod +x ${S}/waf
}
FILES_${PN} += "${datadir}/icons"