aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-05-31 12:36:28 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:25 +0200
commit240e2ebe4371f15fad37b31bd3db83aa0ab42522 (patch)
tree3f5eb7c6c1e8cc47061f80d4f405b35e90cfb302
parent852cd67b916cdbe9f91d5323fe2a6cc790a7a0eb (diff)
downloadmeta-openembedded-contrib-240e2ebe4371f15fad37b31bd3db83aa0ab42522.tar.gz
plymouth: allow disabling the dracut dep
Add a 'initrd' PACKAGECONFIG to disable emission of the plymouth-initrd package which includes initramfs files for use by dracut. Disabling this will avoid the runtime dependency on dracut, which is useful if one doesn't need or want dracut and doesn't want to pull in meta-initramfs. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb18
1 files changed, 11 insertions, 7 deletions
diff --git a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
index 9ca8502818..de23dcd5b9 100644
--- a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
+++ b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
@@ -24,29 +24,33 @@ EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-docum
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \
"
+PACKAGECONFIG ??= "pango initrd"
+PACKAGECONFIG_append_x86 = " drm"
+PACKAGECONFIG_append_x86-64 = " drm"
+
PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm"
PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+"
-
-PACKAGECONFIG ??= "pango"
+PACKAGECONFIG[initrd] = ",,,"
LOGO ??= "${datadir}/plymouth/bizcom.png"
-PACKAGECONFIG_append_x86 = " drm"
-PACKAGECONFIG_append_x86-64 = " drm"
-
inherit autotools pkgconfig systemd
-
do_install_append() {
install -d ${D}${systemd_unitdir}/system
install -m 644 ${B}/systemd-units/*.service ${D}${systemd_unitdir}/system
install -m 644 ${B}/systemd-units/systemd-ask-password-plymouth.path ${D}${systemd_unitdir}/system
# Remove /var/run from package as plymouth will populate it on startup
rm -fr "${D}${localstatedir}/run"
+
+ if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then
+ rm -rf "${D}${libexecdir}"
+ fi
}
-PACKAGES =+ "${PN}-initrd ${PN}-set-default-theme"
+PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'initrd', '${PN}-initrd ', '', d)}"
+PACKAGES =+ "${PN}-set-default-theme"
FILES_${PN}-initrd = "${libexecdir}/plymouth/*"
FILES_${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme"