aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-03-06 16:43:10 +0800
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:21 -0800
commit9111c760d9baea4e59db0066eb592bba127b5341 (patch)
tree77459fa5ff39e46ec46a96010d5d978217890f04
parentdd82a3ab81b48998decfcf7bab41651d7d1a1ea2 (diff)
downloadmeta-openembedded-contrib-9111c760d9baea4e59db0066eb592bba127b5341.tar.gz
libtalloc: upgrade 2.4.1 -> 2.4.2
0001-talloc-Add-configure-options-for-packages.patch refreshed for 2.4.2 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/libtalloc/libtalloc/0001-talloc-Add-configure-options-for-packages.patch39
-rw-r--r--meta-networking/recipes-support/libtalloc/libtalloc_2.4.2.bb (renamed from meta-networking/recipes-support/libtalloc/libtalloc_2.4.1.bb)2
2 files changed, 33 insertions, 8 deletions
diff --git a/meta-networking/recipes-support/libtalloc/libtalloc/0001-talloc-Add-configure-options-for-packages.patch b/meta-networking/recipes-support/libtalloc/libtalloc/0001-talloc-Add-configure-options-for-packages.patch
index 45d847c852..6c92beb30b 100644
--- a/meta-networking/recipes-support/libtalloc/libtalloc/0001-talloc-Add-configure-options-for-packages.patch
+++ b/meta-networking/recipes-support/libtalloc/libtalloc/0001-talloc-Add-configure-options-for-packages.patch
@@ -24,13 +24,16 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com>
Rebase to 2.4.1
Remove libaio option
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+
+Rebase to 2.4.2
+Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
- lib/replace/wscript | 78 +++++++++++++++++++++++++++++++++------------
- wscript | 7 +++-
- 2 files changed, 64 insertions(+), 21 deletions(-)
+ lib/replace/wscript | 100 ++++++++++++++++++++++++++++++--------------
+ wscript | 7 +++-
+ 2 files changed, 75 insertions(+), 32 deletions(-)
diff --git a/lib/replace/wscript b/lib/replace/wscript
-index 199e636..3593eaf 100644
+index 77e655b..2fd7dfb 100644
--- a/lib/replace/wscript
+++ b/lib/replace/wscript
@@ -25,6 +25,34 @@ def options(opt):
@@ -112,7 +115,7 @@ index 199e636..3593eaf 100644
conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h')
conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h')
conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h')
-@@ -443,20 +481,20 @@ def configure(conf):
+@@ -443,31 +481,31 @@ def configure(conf):
strlcpy_in_bsd = False
@@ -121,6 +124,17 @@ index 199e636..3593eaf 100644
- if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
- checklibc=True):
- strlcpy_in_bsd = True
+- elif conf.env.enable_fuzzing:
+- # Just to complicate it more, some versions of Honggfuzz have
+- # got strlcpy and strlcat in libc, but not in <string.h>
+- # (unless it is there coincidentally, on a BSD). Therefore we
+- # can't use CHECK_FUNCS alone to decide whether to add the
+- # headers to replace.h.
+- #
+- # As this is only known to happen on a fuzzing compiler, we'll
+- # skip the check when not in fuzzing mode.
+- conf.CHECK_HEADERS('bsd/string.h')
+-
- if not conf.CHECK_FUNCS('getpeereid'):
- conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
- if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'):
@@ -136,6 +150,17 @@ index 199e636..3593eaf 100644
+ if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
+ checklibc=True):
+ strlcpy_in_bsd = True
++ elif conf.env.enable_fuzzing:
++ # Just to complicate it more, some versions of Honggfuzz have
++ # got strlcpy and strlcat in libc, but not in <string.h>
++ # (unless it is there coincidentally, on a BSD). Therefore we
++ # can't use CHECK_FUNCS alone to decide whether to add the
++ # headers to replace.h.
++ #
++ # As this is only known to happen on a fuzzing compiler, we'll
++ # skip the check when not in fuzzing mode.
++ conf.CHECK_HEADERS('bsd/string.h')
++
+ if not conf.CHECK_FUNCS('getpeereid'):
+ conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
+ if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'):
@@ -148,7 +173,7 @@ index 199e636..3593eaf 100644
conf.CHECK_CODE('''
struct ucred cred;
diff --git a/wscript b/wscript
-index 075f1ec..6b4f273 100644
+index 8b5e02d..b6e2614 100644
--- a/wscript
+++ b/wscript
@@ -31,7 +31,12 @@ def options(opt):
@@ -166,5 +191,5 @@ index 075f1ec..6b4f273 100644
def configure(conf):
conf.RECURSE('lib/replace')
--
-2.25.1
+2.34.1
diff --git a/meta-networking/recipes-support/libtalloc/libtalloc_2.4.1.bb b/meta-networking/recipes-support/libtalloc/libtalloc_2.4.2.bb
index 92da03e1a1..394c176287 100644
--- a/meta-networking/recipes-support/libtalloc/libtalloc_2.4.1.bb
+++ b/meta-networking/recipes-support/libtalloc/libtalloc_2.4.2.bb
@@ -14,7 +14,7 @@ SRC_URI = "https://www.samba.org/ftp/talloc/talloc-${PV}.tar.gz \
file://0002-Fix-pyext_PATTERN-for-cross-compilation.patch \
file://run-ptest \
"
-SRC_URI[sha256sum] = "410a547f08557007be0e88194f218868358edc0ab98c98ba8c167930db3d33f9"
+SRC_URI[sha256sum] = "85ecf9e465e20f98f9950a52e9a411e14320bc555fa257d87697b7e7a9b1d8a6"
inherit waf-samba pkgconfig ptest