aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYusuke Mitsuki <mickey.happygolucky@gmail.com>2017-08-08 09:59:14 +0900
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-13 13:20:59 +0200
commite44af0d743529b3ccbb86dce22d6b719ba9c5e90 (patch)
treee893b76e2c29e55cfb0cc4c7bb97831d4c083b0e
parent087348874fdf82183c7609148bebec64be885c20 (diff)
downloadmeta-openembedded-contrib-e44af0d743529b3ccbb86dce22d6b719ba9c5e90.tar.gz
meta-openembedded-contrib-e44af0d743529b3ccbb86dce22d6b719ba9c5e90.tar.bz2
meta-openembedded-contrib-e44af0d743529b3ccbb86dce22d6b719ba9c5e90.zip
uim: Fixed a problem that an immodule.cache is not updated appropriately when uim-gtk2.0 or uim-gtk3 was installed.
pkg_postinst_uim-gtk2.0 is not worked. Plus, uim-gtk3 is not supported. oe-core has gtk-immodule-cache class for update the immodule.cache. Modified to use the this class instead of pkg_post_uim-gtk2.0 and added support to uim-gtk3. Signed-off-by: Yusuke Mitsuki <mickey.happygolucky@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/uim/uim_1.8.6.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/uim/uim_1.8.6.bb b/meta-oe/recipes-support/uim/uim_1.8.6.bb
index 395bca2522..271718e5e4 100644
--- a/meta-oe/recipes-support/uim/uim_1.8.6.bb
+++ b/meta-oe/recipes-support/uim/uim_1.8.6.bb
@@ -21,7 +21,8 @@ RDEPENDS_uim-anthy = "takao-fonts anthy libanthy0 glibc-utils glibc-gconv-euc-jp
LEAD_SONAME = "libuim.so.1"
-inherit autotools pkgconfig gettext qemu
+inherit autotools pkgconfig gettext qemu gtk-immodules-cache
+GTKIMMODULES_PACKAGES = "uim-gtk2.0 uim-gtk3"
EXTRA_OECONF += "--disable-emacs \
--without-scim \
@@ -120,10 +121,6 @@ pkg_prerm_uim-anthy() {
fi
}
-pkg_postinst_uim-gtk2.0() {
- gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
-}
-
pkg_postinst_uim-skk() {
if test -n "$D"; then
${@qemu_run_binary(d, '$D', '${bindir}/uim-module-manager')} --register skk --path $D${datadir}/uim