aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-11-26 12:28:18 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-12-04 10:42:39 +0100
commit07e9ca6888c728c4c9d3d3631b901c603d247beb (patch)
treef86c192dcbb366368aa58bdaeea86da909566207
parent85ab35f4edac91ecc180161e97c6698f1c10928b (diff)
downloadmeta-openembedded-contrib-07e9ca6888c728c4c9d3d3631b901c603d247beb.tar.gz
meta-oe: add python-mako, a templating library
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-devtools/python/python-mako-native_0.7.2.bb6
-rw-r--r--meta-oe/recipes-devtools/python/python-mako_0.7.2.bb19
2 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-mako-native_0.7.2.bb b/meta-oe/recipes-devtools/python/python-mako-native_0.7.2.bb
new file mode 100644
index 0000000000..0d4c1e4ae9
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-mako-native_0.7.2.bb
@@ -0,0 +1,6 @@
+require python-mako_${PV}.bb
+inherit native pythonnative
+
+DEPENDS = "python-native"
+RDEPENDS_${PN} = ""
+PR = "r0"
diff --git a/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb b/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb
new file mode 100644
index 0000000000..9113666a9f
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Templating library for Python"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=da8dd26ed9751ee0cfdf9df1a16bbb54"
+
+PR = "r0"
+
+SRC_URI = "http://www.makotemplates.org/downloads/Mako-${PV}.tar.gz"
+SRC_URI[md5sum] = "e3c0a677aa4216da9e89ef8fa76cbafb"
+SRC_URI[sha256sum] = "fe8698e845035586bd711a6748e4e40a208a58de276b9138026164700494b68f"
+
+S = "${WORKDIR}/Mako-${PV}"
+
+inherit distutils
+
+RDEPENDS_${PN} = "python-threading \
+ python-netclient \
+ python-html \
+ "