aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-29 02:02:53 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-29 02:10:12 -0700
commit08ab868140cd2168e4baa394bf64ee14abc55e12 (patch)
treeb698f2ec88d8742a3befb25fb3996f4bde0b467a
parent70a0692211a396a616507e660fa6dd8a14c16190 (diff)
downloadmeta-openembedded-contrib-08ab868140cd2168e4baa394bf64ee14abc55e12.tar.gz
grpc-native: Fix buld on ubuntu 14.04 with gcc 4.8
Fixes a compiler error terminate called after throwing an instance of 'std::system_error' what(): Enable multithreading to use std::thread: Operation not permitted Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-devtools/grpc/grpc_1.14.1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-networking/recipes-devtools/grpc/grpc_1.14.1.bb b/meta-networking/recipes-devtools/grpc/grpc_1.14.1.bb
index 784e0d2b4b..7b3f73657c 100644
--- a/meta-networking/recipes-devtools/grpc/grpc_1.14.1.bb
+++ b/meta-networking/recipes-devtools/grpc/grpc_1.14.1.bb
@@ -17,6 +17,9 @@ SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;branch=${BRANCH} \
"
SRC_URI_append_class-target = " file://0001-CMakeLists.txt-Fix-grpc_cpp_plugin-path-during-cross.patch"
+# Fixes build with older compilers 4.8 especially on ubuntu 14.04
+CXXFLAGS_append_class-native = " -Wl,--no-as-needed"
+
inherit cmake
EXTRA_OECMAKE = " \