aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-22 16:43:40 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-10 12:25:40 +0200
commit23961504590ff7e962e097a94567d9f862494568 (patch)
treeb9476fd6b60099fd92ab98547b344cf93d4fc1e1
parentdf58431f76f7d3aadc5e8204d6fe8aa3c2bfc423 (diff)
downloadmeta-openembedded-contrib-23961504590ff7e962e097a94567d9f862494568.tar.gz
ruby overwrites configuration files in ruby-native
ruby's install rule is calling install-cross, this overwrites files installed by ruby-native causing build failures with ruby apps, specifically where gems are involved, especially on hosts where there is no host ruby: (from sysroot-native's gem) gem env RubyGems Environment: - RUBYGEMS VERSION: 1.8.23 - RUBY VERSION: 1.9.3 (2012-04-20 patchlevel 194) [x86_64-linux] - INSTALLATION DIRECTORY: /usr/lib64/ruby/gems/1.9.1 - RUBY EXECUTABLE: /usr/bin/ruby - EXECUTABLE DIRECTORY: /usr/bin - RUBYGEMS PLATFORMS: - ruby - x86_64-linux - GEM PATHS: - /usr/lib64/ruby/gems/1.9.1 - /folk/afong/.gem/ruby/1.9.1 - GEM CONFIGURATION: - :update_sources => true - :verbose => true - :benchmark => false - :backtrace => false - :bulk_threshold => 1000 - REMOTE SOURCES: - http://rubygems.org/ Files affected - fake.rb, rbconfig.rb, config.h, win32.h and ruby libraries. We should be using the versions from ruby-native. Signed-off-by: Amy Fong <amy.fong@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb
index 48a65a948b..ddba0da24b 100644
--- a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb
+++ b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb
@@ -33,11 +33,7 @@ EXTRA_OEMAKE = " \
"
do_install() {
- if [ ${PN} = "ruby" ]; then
- oe_runmake 'DESTDIR=${D}' install install-cross
- else
- oe_runmake 'DESTDIR=${D}' install
- fi
+ oe_runmake 'DESTDIR=${D}' install
}
FILES_${PN} += "${datadir}/rubygems \