aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic PAUT <frederic.paut@linux.intel.com>2013-10-03 13:31:41 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-05 12:40:35 +0200
commit7a541bd4baab7e6f23f998fcf6509ee2817b018b (patch)
tree430c04ad4c163a183d141ff41806508c6eca1d92
parent68f092aa8bb3499042138e0b010ad5b64558b8aa (diff)
downloadmeta-openembedded-contrib-7a541bd4baab7e6f23f998fcf6509ee2817b018b.tar.gz
python-autobahn: Add recipe for 0.5.14
AutobahnPython provides a WebSocket (RFC6455, Hybi-10 to -17, Hixie-76) framework for creating WebSocket-based clients and servers. AutobahnPython also includes an implementation of WAMP (The WebSockets Application Messaging Protocol), a light-weight, asynchronous RPC/PubSub over JSON/WebSocket protocol. Signed-off-by: Frederic PAUT <frederic.paut@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-autobahn_0.5.14.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-autobahn_0.5.14.bb b/meta-oe/recipes-devtools/python/python-autobahn_0.5.14.bb
new file mode 100644
index 0000000000..0208c8b50e
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-autobahn_0.5.14.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "AutobahnPython provides a WebSocket (RFC6455, Hybi-10 to -17, Hixie-76) framework for creating WebSocket-based clients and servers. \
+AutobahnPython also includes an implementation of WAMP (The WebSockets Application Messaging Protocol), a light-weight, \
+asynchronous RPC/PubSub over JSON/WebSocket protocol."
+HOMEPAGE = "http://autobahn.ws/python"
+SECTION = "console/network"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = " file://autobahn/__init__.py;beginline=1;endline=17;md5=81964ceb3ab93bfb5e8cfbcd26f3af9c"
+
+SRC_URI = "https://pypi.python.org/packages/source/a/autobahn/autobahn-${PV}.zip"
+SRC_URI[md5sum] = "e2c80ba3e46428b32837537609d4d582"
+
+S = "${WORKDIR}/autobahn-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} = "python python-pprint python-twisted-protocols python-netserver python-twisted-web"
+