aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDomarys Correa <domarys.correa@ossystems.com.br>2020-05-26 13:47:21 -0300
committerArmin Kuster <akuster808@gmail.com>2020-06-12 09:32:04 -0700
commit7c83566d74815b03ff20af636b8c708bf0b4d862 (patch)
tree4d5bc3a4c0d635a572ceaadb8f84cec02a310dec
parent94e42d9b95342078ae3d6c879f0eb3c408f9bc24 (diff)
downloadmeta-openembedded-contrib-7c83566d74815b03ff20af636b8c708bf0b4d862.tar.gz
python3-pyyaml: Update 5.3 -> 5.3.1
Signed-off-by: Domarys Correa <domarys.correa@ossystems.com.br> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 6a7ef1fbb8342d31b76128b102e028844b6f3c98) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pyyaml_5.3.1.bb18
-rw-r--r--meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb19
2 files changed, 18 insertions, 19 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyyaml_5.3.1.bb b/meta-python/recipes-devtools/python/python3-pyyaml_5.3.1.bb
new file mode 100644
index 0000000000..8cf9093041
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyyaml_5.3.1.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Python support for YAML"
+DEPENDS += "libyaml ${PYTHON_PN}-cython-native"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7bbd28caa69f81f5cd5f48647236663d"
+
+PYPI_PACKAGE = "PyYAML"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "b8eac752c5e14d3eca0e6dd9199cd627518cb5ec06add0de9d32baeee6fe645d"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-netclient \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb b/meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb
deleted file mode 100644
index 17868a25dd..0000000000
--- a/meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "Python support for YAML"
-HOMEPAGE = "http://www.pyyaml.org"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=a76b4c69bfcf82313bbdc0393b04438a"
-DEPENDS = "libyaml ${PYTHON_PN}-cython-native ${PYTHON_PN}"
-
-PYPI_PACKAGE = "PyYAML"
-inherit pypi setuptools3
-
-SRC_URI[md5sum] = "adbb0d336b509d6472d3b095a0f1cf30"
-SRC_URI[sha256sum] = "e9f45bd5b92c7974e59bcd2dcc8631a6b6cc380a904725fce7bc08872e691615"
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-datetime \
- ${PYTHON_PN}-netclient \
-"
-
-BBCLASSEXTEND = "native nativesdk"