aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-10-01 23:34:09 +0000
committerEric Bénard <eric@eukrea.com>2013-10-02 11:05:44 +0200
commitd0141728c5b5f61598964947690da54d2f91f10b (patch)
treee426c5716bf91a4b7507a3ed65c1d8390c052de8
parent989f72c2b5d98282c8e7de04b8b961a1a320d443 (diff)
downloadmeta-openembedded-contrib-d0141728c5b5f61598964947690da54d2f91f10b.tar.gz
krb5: Backport patch to fix parallel build
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--meta-oe/recipes-connectivity/krb5/krb5/055d1ffa81d0730e92aa3f1ed5045cd805c74957.patch49
-rw-r--r--meta-oe/recipes-connectivity/krb5/krb5_1.11.bb4
2 files changed, 52 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/krb5/krb5/055d1ffa81d0730e92aa3f1ed5045cd805c74957.patch b/meta-oe/recipes-connectivity/krb5/krb5/055d1ffa81d0730e92aa3f1ed5045cd805c74957.patch
new file mode 100644
index 0000000000..d92f5c63a7
--- /dev/null
+++ b/meta-oe/recipes-connectivity/krb5/krb5/055d1ffa81d0730e92aa3f1ed5045cd805c74957.patch
@@ -0,0 +1,49 @@
+From 055d1ffa81d0730e92aa3f1ed5045cd805c74957 Mon Sep 17 00:00:00 2001
+From: Nickolai Zeldovich <nickolai@csail.mit.edu>
+Date: Sun, 3 Mar 2013 01:38:22 -0500
+Subject: [PATCH] Fix dependencies in tests/gssapi
+
+Use $(COMMON_DEPS) instead of $(COMMON_DEPLIBS) for dependencies; the
+latter appears to be a typo. Fixes build when using "make -j".
+
+ticket: 7587 (new)
+target_version: 1.11.2
+tags: pullup
+
+Upstream-Status: Backport
+http://krbdev.mit.edu/rt/Ticket/Display.html?id=7587
+
+---
+ tests/gssapi/Makefile.in | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/tests/gssapi/Makefile.in b/tests/gssapi/Makefile.in
+index 5620234..6a5870b 100644
+--- a/tests/gssapi/Makefile.in
++++ b/tests/gssapi/Makefile.in
+@@ -45,11 +45,11 @@ t_accname: t_accname.o $(COMMON_DEPS)
+ $(CC_LINK) -o $@ t_accname.o $(COMMON_LIBS)
+ t_ccselect: t_ccselect.o $(COMMON_DEPS)
+ $(CC_LINK) -o $@ t_ccselect.o $(COMMON_LIBS)
+-t_credstore: t_credstore.o $(COMMON_DEPLIBS)
++t_credstore: t_credstore.o $(COMMON_DEPS)
+ $(CC_LINK) -o $@ t_credstore.o $(COMMON_LIBS)
+ t_export_cred: t_export_cred.o $(COMMON_DEPS)
+ $(CC_LINK) -o $@ t_export_cred.o $(COMMON_LIBS)
+-t_export_name: t_export_name.o $(COMMON_DEPLIBS)
++t_export_name: t_export_name.o $(COMMON_DEPS)
+ $(CC_LINK) -o $@ t_export_name.o $(COMMON_LIBS)
+ t_gssexts: t_gssexts.o $(COMMON_DEPS)
+ $(CC_LINK) -o $@ t_gssexts.o $(COMMON_LIBS)
+@@ -67,7 +67,7 @@ t_s4u: t_s4u.o $(COMMON_DEPS)
+ $(CC_LINK) -o $@ t_s4u.o $(COMMON_LIBS)
+ t_s4u2proxy_krb5: t_s4u2proxy_krb5.o $(COMMON_DEPS)
+ $(CC_LINK) -o $@ t_s4u2proxy_krb5.o $(COMMON_LIBS)
+-t_saslname: t_saslname.o $(COMMON_DEPLIBS)
++t_saslname: t_saslname.o $(COMMON_DEPS)
+ $(CC_LINK) -o $@ t_saslname.o $(COMMON_LIBS)
+ t_spnego: t_spnego.o $(COMMON_DEPS)
+ $(CC_LINK) -o $@ t_spnego.o $(COMMON_LIBS)
+--
+1.8.4
+
diff --git a/meta-oe/recipes-connectivity/krb5/krb5_1.11.bb b/meta-oe/recipes-connectivity/krb5/krb5_1.11.bb
index a68e85d131..63676fd2b6 100644
--- a/meta-oe/recipes-connectivity/krb5/krb5_1.11.bb
+++ b/meta-oe/recipes-connectivity/krb5/krb5_1.11.bb
@@ -9,7 +9,9 @@ inherit autotools binconfig perlnative
PR = "r2"
-SRC_URI = "http://web.mit.edu/kerberos/dist/${PN}/${PV}/${P}-signed.tar"
+SRC_URI = "http://web.mit.edu/kerberos/dist/${PN}/${PV}/${P}-signed.tar \
+ file://055d1ffa81d0730e92aa3f1ed5045cd805c74957.patch \
+"
SRC_URI[md5sum] = "1a13c53899806c4da99a798a04d25545"
SRC_URI[sha256sum] = "fe37fb93b398db98a1b23f814673ea2ae4b90138f85e1a4027ef639456a78651"