aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSakib Sajal <sakib.sajal@windriver.com>2020-11-03 13:12:44 -0500
committerKhem Raj <raj.khem@gmail.com>2020-11-03 11:03:45 -0800
commitb3e9b51c9ba58b01e55c5b0a9a9bec3f7f06d07a (patch)
tree80ae6333f3842e3d60fd2d136ca16f73715ef663
parent2fe4cb5882d57244914b431a2f4ba58b8faf9756 (diff)
downloadmeta-openembedded-contrib-b3e9b51c9ba58b01e55c5b0a9a9bec3f7f06d07a.tar.gz
libssh2: fix ptest
One of the ptest was failing as it was missing an RDEPENDS for its test on documentation. Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libssh2/files/run-ptest5
-rw-r--r--meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb6
2 files changed, 8 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/libssh2/files/run-ptest b/meta-oe/recipes-support/libssh2/files/run-ptest
index 2a7922f1aa..c213b32e5f 100644
--- a/meta-oe/recipes-support/libssh2/files/run-ptest
+++ b/meta-oe/recipes-support/libssh2/files/run-ptest
@@ -1,7 +1,8 @@
#!/bin/sh
ptestdir=$(dirname "$(readlink -f "$0")")
-for test in $(ls $ptestdir/tests)
+cd tests
+for test in $(ls)
do
- ./test-driver --test-name $test --log-file $test.log --trs-file $test.trs --color-tests no --enable-hard-errors yes --expect-failure no -- ./tests/$test
+ ./../test-driver --test-name $test --log-file ../$test.log --trs-file ../$test.trs --color-tests no --enable-hard-errors yes --expect-failure no -- ./$test
done
diff --git a/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb b/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb
index a1d85617a6..38f1626935 100644
--- a/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb
+++ b/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb
@@ -28,7 +28,9 @@ PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGI
BBCLASSEXTEND = "native nativesdk"
-RDEPENDS_${PN}-ptest = "bash"
+# required for ptest on documentation
+RDEPENDS_${PN}-ptest = "man-db"
+RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us"
do_compile_ptest() {
sed -i "/\$(MAKE) \$(AM_MAKEFLAGS) check-TESTS/d" tests/Makefile
@@ -40,4 +42,6 @@ do_install_ptest() {
install -m 0755 ${B}/tests/.libs/simple ${D}${PTEST_PATH}/tests/
install -m 0755 ${S}/tests/mansyntax.sh ${D}${PTEST_PATH}/tests/
install -m 0755 ${S}/test-driver ${D}${PTEST_PATH}/
+ mkdir -p ${D}${PTEST_PATH}/docs
+ cp -r ${S}/docs/* ${D}${PTEST_PATH}/docs/
}